IMAP SSL log-in hangs with Mac OS X

VERIFIED FIXED

Status

MailNews Core
Networking: IMAP
P2
critical
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: Steve, Assigned: Bienvenu)

Tracking

({hang})

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Using Courier-SSL for IMAP server w/ MacOS X 10.2 on client

- Open mail app
- Click on account in left window pane
- User input menu drops from window title bar but is blank
- Entire application hangs with the spinning colored ball. Eventually have to
force-quit.
- Tried with 8/23 build and 1.1 B with similar results.

Misc:
- Logging into IMAP server with no SSL works fine.
- Logging into IMAP w/SSL worked fine when I had MacOS X 10.1.5 and Moz >= 1.1B

Updated

15 years ago
Keywords: hang

Comment 1

15 years ago
Severity critical, not blocker.
Severity: blocker → critical

Updated

15 years ago
QA Contact: huang → junruh

Comment 2

15 years ago
Confirming on trunk. This appeared on the 8/22 trunk build and applies to Mac 
OSX 10.1.5 also. The 8/21 trunk build is OK.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Summary: IMAP SSL log-in hangs with MacOS X 10.2 → IMAP SSL log-in hangs with MacOSX

Comment 3

15 years ago
sunkcost@pobox.com, in your step 3, by "user input menu" do you mean the
username and password dialog?

With my mac.com username and password previously stored in the Password Manager,
I  can connect to mail.mac.com via IMAP+SSL successfully using 2002-08-18-1.1.
Summary: IMAP SSL log-in hangs with MacOSX → IMAP SSL log-in hangs with Mac OS X

Comment 4

15 years ago
I don't see SSL related checkins to security/manager between 08/20-08/22.

Comment 5

15 years ago
Nelson, Wan-Teh, do you know, whether SSL logic has changed on NSS_CLIENT_TAG on
08/21? I don't know how I could check myself with Bonsai, since it's a static tag.
Status: NEW → ASSIGNED

Comment 6

15 years ago
Wan-Teh told me, the current base for NSS logic on the Mozilla trunk is
NSS_3_5_BRANCH, and no checkins to that branch have been made after 08/04. It
seems security/SSL logic can not have caused this regression.


I looked on Bonsai who checked in to netwerk or mailnews/imap on the regression
date. See here for the list of checkins:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=%2Fmozilla%2Fnetwerk%2F+%2Fmozilla%2Fmailnews%2Fimap%2F&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=08%2F20&maxdate=08%2F22&cvsroot=%2Fcvsroot


cc'ing people who checked in.

Unfortunately I don't have a Mac (yet).
(Assignee)

Comment 7

15 years ago
I might have a fix for this already.
Assignee: mscott → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 8

15 years ago
My guess is that the fix for bug 164404 will fix this too. Please try with
tomorrow's build, thx.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
Verified on the 8/27 trunk Mac OSX build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.