Drop down filter menu doesn't show initial value

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: Vladimir, Assigned: Mike Potter)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla Calendar 2002082317-cal
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020824

Caledar does not Show  the Type of the Event on the first pop up
(Reporter)

Comment 1

16 years ago
Created attachment 96609 [details]
Screenshot of the bug
(Assignee)

Comment 2

16 years ago
I don't understand what you are trying to say...
Please spell out exactly what the problem is, what steps I can do to reproduce
the problem, and what you think should happen instead.
(Reporter)

Comment 3

16 years ago
"I don't understand what you are trying to say" - 
I attached the snapshot to make it clear.

01. Open the attached snapshot of the bug.
02. Right underneath the calendar itself we see
    the singleline edit labeled "Event contains".
03. Right underneath this singleline edit we see
    the unlabeled dropdown which contains no text when we
    open the calendar.
04. But as you can see on the snapshot the down list of this
    dropdown contains several entries (what I call type
    of the event (???) - because this dropdown does NOT have label) and
    one of these entries ("Today's Events") is checked.
05. So we see the default initial type (class???) of the even which
    is selected in the down list but it is not shown in the dropdown itself.
06. When the Calendar is open on the first time this (unlabeled) dropdown
    must show "Today's Events".

Note: I think that this dropdown should have a label.
(Assignee)

Comment 4

16 years ago
OK, this wasn't clear to me in your first post.
I see what you're saying now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Caledar does not Show the Type of the Event on the first pop up → Drop down filter menu doesn't show initial value
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Depends on: 118038
(Assignee)

Comment 5

16 years ago
Fixed this by doing this:
document.getElementById( 'event-filter-menulist' ).setAttribute( "label",
document.getElementById( 'event-filter-menulist' ).selectedItem.getAttribute(
'label' ) );
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 118038
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: colint → sunbird
You need to log in before you can comment on or make changes to this bug.