System settings are saved under HKEY_LOCAL_MACHINE

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
16 years ago
8 years ago

People

(Reporter: kazhik, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
System settings by [Advanced]-[System] are saved under HKEY_LOCAL_MACHINE
in Windows registry. But it should be saved under HKEY_CURRENT_USER.

http://www.microsoft.com/windows2000/techinfo/reskit/en-us/default.asp?url=/windows2000/techinfo/reskit/en-us/regentry/69673.asp

Comment 1

16 years ago
Windows treats HKEY_LOCAL_MACHINE as default for backward compatibility,
but Mozilla should save system settings under HKEY_CURRENT_USER if possible,
because Mozilla saves other settings (such as quick launch) under HKEY_CURRENT_USER
not HKEY_LOCAL_MACHINE.

Comment 2

16 years ago
I have no idea where this belongs, but BackEnd Prefs does not talk to the
Windows registry. guessing XPApps...
Assignee: bnesse → sgehani
Component: Preferences: Backend → XP Apps
QA Contact: rvelasco → paw
Product: Core → Mozilla Application Suite

Comment 3

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.