If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when entering this web site

RESOLVED DUPLICATE of bug 154699

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 154699
15 years ago
7 years ago

People

(Reporter: David Weiser, Assigned: Joe Chou)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020815
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020815

I am running OSX 10.2 using the same mozilla version when I was running 10.1 and
Mozilla crashes when browsing www.talk2.com.  This did not happen when I was
runing OSX 10.1

Reproducible: Always

Steps to Reproduce:
1.http://www.talk2k.com
2.
3.

Actual Results:  
Mozilla and I get a "mozilla quit un-expectedly"

Expected Results:  
Web page should be browseable

Crash log:


Mozilla.crash.log:	
    2002-08-25 21:52:28 -0500:	
            Date/Time:  2002-08-25 21:52:28 -0500
            OS Version: 10.2 (Build 6C115)
            Host:       David-Weisers-Computer.local.
            
            Command:    Mozilla
            PID:        1019
            
            Exception:  EXC_BAD_ACCESS (0x0001)
            Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000034
            
            Thread 0:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x9283ddf4 in JVM_NewInstance
             #3   0x9284ee30 in JVM_GetCPMethodClassNameUTF
             #4   0x92861a94 in JVM_Send
             #5   0x9285eb14 in JVM_FillInStackTrace
             #6   0x92868468 in JVM_DoPrivileged
             #7   0x9288e0e0 in JVM_GetMethodIxExceptionTableEntry
             #8   0x92883e80 in JVM_DefineClass
             #9   0x929ba848 in eh_rest_world_r10
             #10  0x928499b8 in __moddi3
             #11  0x928af2cc in JVM_IsNaN
             #12  0x07864c90 in 0x7864c90
             #13  0x07872d90 in 0x7872d90
             #14  0x07871dcc in 0x7871dcc
             #15  0x07873f24 in 0x7873f24
             #16  0x07866e60 in 0x7866e60
             #17  0x0776468c in 0x776468c
             #18  0x0776468c in 0x776468c
             #19  0x077645cc in 0x77645cc
             #20  0x077645cc in 0x77645cc
             #21  0x077645cc in 0x77645cc
             #22  0x077645cc in 0x77645cc
             #23  0xa2843c38 in typeinfo name for std::bad_exception
             #24  0x92838bdc in JVM_CurrentTimeMillis
             #25  0x92872ed4 in JVM_GetCPClassNameUTF
             #26  0x92865c80 in JVM_DoPrivileged
             #27  0x07766668 in 0x7766668
             #28  0x077645cc in 0x77645cc
             #29  0xa2843c38 in typeinfo name for std::bad_exception
             #30  0x92838bdc in JVM_CurrentTimeMillis
             #31  0x92872ed4 in JVM_GetCPClassNameUTF
             #32  0x9288f144 in JVM_MonitorNotifyAll
             #33  0x9285fd68 in JVM_GetCPFieldSignatureUTF
             #34  0x92844a98 in JVM_GetClassLoader
             #35  0x92875e64 in JVM_GetCPClassNameUTF
             #36  0x9288199c in JVM_DefineClass
             #37  0x92869ed4 in JVM_DoPrivileged
             #38  0x928480dc in __moddi3
             #39  0x0776cd7c in 0x776cd7c
             #40  0xa2843c38 in typeinfo name for std::bad_exception
             #41  0x92838bdc in JVM_CurrentTimeMillis
             #42  0x92872ed4 in JVM_GetCPClassNameUTF
             #43  0x9288f144 in JVM_MonitorNotifyAll
             #44  0x9285fd68 in JVM_GetCPFieldSignatureUTF
             #45  0x92844a98 in JVM_GetClassLoader
             #46  0x9285fc40 in JVM_GetCPFieldSignatureUTF
             #47  0x92844a98 in JVM_GetClassLoader
             #48  0x9285fc40 in JVM_GetCPFieldSignatureUTF
             #49  0x92844a98 in JVM_GetClassLoader
             #50  0x9285fc40 in JVM_GetCPFieldSignatureUTF
             #51  0x92844a98 in JVM_GetClassLoader
             #52  0x9285fc40 in JVM_GetCPFieldSignatureUTF
             #53  0x92844a98 in JVM_GetClassLoader
             #54  0x928452e8 in JVM_GetMethodIxExceptionTableLength
             #55  0x928a22c4 in JVM_Close
             #56  0x8cfd23e4 in
com_apple_mrj_JavaEmbedding_JE_AppletViewer::intitializeMethodIDs(JNIEnv_*)
             #57  0x8cfd1dec in intitializeAllMethodIDs(JNIEnv_*)
             #58  0x8cfd3068 in InitJavaEmbedding(JNIEnv_*&)
             #59  0x8cfd57d4 in CreateJavaApplet
             #60  0x01fef734 in MRJContext::loadApplet(void)
             #61  0x01ff0298 in MRJContext::setWindow(nsPluginWindow *)
             #62  0x01febea4 in MRJPluginInstance::SetWindow(nsPluginWindow *)
             #63  0x01facabc in
InstantiateEmbededPlugin__16nsPluginHostImplFPCcP6nsIURIP22nsI
             #64  0x02354b94 in
InstantiatePlugin__13nsObjectFrameFP14nsIPresContextR19nsHTMLR
             #65  0x023538d0 in 0x23538d0
             #66  0x02389fc0 in 0x2389fc0
             #67  0x02383624 in
ReflowInlineFrame__12nsBlockFrameFR18nsBlockReflowStateR12nsLi
             #68  0x02383338 in
DoReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowStateR12n
             #69  0x023830f8 in
nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState &)
             #70  0x02382e78 in
ReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowState19nsLi
             #71  0x02381298 in
ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_i
             #72  0x02380884 in 0x2380884
             #73  0x0237ec54 in nsBlockFrame::Reflow(nsIPresContext *,
nsHTMLReflowMetrics &)
             #74  0x023a7f38 in
DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14ns
             #75  0x023a7998 in
ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsC
             #76  0x023827b8 in 0x23827b8
             #77  0x02380ebc in 0x2380ebc
             #78  0x02380884 in 0x2380884
             #79  0x0237ec54 in nsBlockFrame::Reflow(nsIPresContext *,
nsHTMLReflowMetrics &)
             #80  0x022da69c in
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
             #81  0x0247f5bc in CanvasFrame::Reflow(nsIPresContext *,
nsHTMLReflowMetrics &,  &)
             #82  0x0243a0d0 in
Reflow__19nsBoxToBlockAdaptorFR16nsBoxLayoutStateP14nsIPresCon
             #83  0x02439ab8 in nsBoxToBlockAdaptor::DoLayout(nsBoxLayoutState &)
             #84  0x024345ac in nsBox::Layout(nsBoxLayoutState &)
             #85  0x024663cc in 0x24663cc
             #86  0x024345ac in nsBox::Layout(nsBoxLayoutState &)
             #87  0x0243d0d8 in
LayoutChildAt__14nsContainerBoxFR16nsBoxLayoutStateP6nsIBoxRC6
             #88  0x02428cdc in
nsGfxScrollFrameInner::LayoutBox(nsBoxLayoutState &, nsIBox *)
             #89  0x024291bc in 0x24291bc
             #90  0x02428d94 in nsGfxScrollFrame::DoLayout(nsBoxLayoutState &)
             #91  0x024345ac in nsBox::Layout(nsBoxLayoutState &)
             #92  0x023f50d0 in nsBoxFrame::Reflow(nsIPresContext *,
nsHTMLReflowMetrics &,  const &)
             #93  0x02427d10 in
Reflow__16nsGfxScrollFrameFP14nsIPresContextR19nsHTMLReflowMet
             #94  0x022da69c in
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
             #95  0x023c5bb0 in
Reflow__13ViewportFrameFP14nsIPresContextR19nsHTMLReflowMetric
             #96  0x022ef108 in
Dispatch__17IncrementalReflowFP14nsIPresContextR19nsHTMLReflow
             #97  0x023006b4 in PresShell::ProcessReflowCommands(int)
             #98  0x02300094 in HandlePLEvent(ReflowEvent *)
             #99  0x002cd9c0 in PL_HandleEvent
             #100 0x002cd82c in PL_ProcessPendingEvents
             #101 0x00273d9c in nsEventQueueImpl::ProcessPendingEvents(void)
             #102 0x016fcbbc in
nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
             #103 0x016fca60 in
nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
             #104 0x01330b14 in Repeater::DoRepeaters(EventRecord const &)
             #105 0x017130f8 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
             #106 0x01712e30 in nsMacMessagePump::DoMessagePump(void)
             #107 0x017127ac in nsAppShell::Run(void)
             #108 0x016cab0c in nsAppShellService::Run(void)
             #109 0x001a400c in main1(int, char **, nsISupports *)
             #110 0x001a4a4c in main
            
            Thread 1:
             #0   0x9000582c in syscall
             #1   0x90515d9c in BSD_waitevent
             #2   0x9051576c in CarbonSelectThreadFunc
             #3   0x90021428 in _pthread_body
            
            Thread 2:
             #0   0x9003f188 in semaphore_wait_signal_trap
             #1   0x9003efa4 in _pthread_cond_wait
             #2   0x9051dda0 in CarbonOperationThreadFunc
             #3   0x90021428 in _pthread_body
            
            Thread 3:
             #0   0x90042d68 in semaphore_timedwait_signal_trap
             #1   0x9003ef94 in _pthread_cond_wait
             #2   0x90233470 in TSWaitOnSemaphoreCommon
             #3   0x9023c298 in TimerThread
             #4   0x90021428 in _pthread_body
            
            Thread 4:
             #0   0x9003f188 in semaphore_wait_signal_trap
             #1   0x9003efa4 in _pthread_cond_wait
             #2   0x90233454 in TSWaitOnSemaphoreCommon
             #3   0x90248b2c in AsyncFileThread(void*)
             #4   0x90021428 in _pthread_body
            
            Thread 5:
             #0   0x9003f188 in semaphore_wait_signal_trap
             #1   0x9003efa4 in _pthread_cond_wait
             #2   0x90525b90 in CarbonInetOperThreadFunc
             #3   0x90021428 in _pthread_body
            
            Thread 6:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x928ec28c in JNI_CreateJavaVM_Impl
             #3   0x928ec224 in JNI_CreateJavaVM_Impl
             #4   0x928a51fc in JVM_GetClassMethodsCount
             #5   0x90021428 in _pthread_body
            
            Thread 7 Crashed:
             #0   0x929ba640 in eh_rest_world_r10
             #1   0x92857a38 in JVM_GetMethodIxLocalsCount
             #2   0x9285c128 in JVM_GetCPMethodNameUTF
             #3   0x928917f4 in JVM_MonitorNotifyAll
             #4   0x92886e6c in JVM_SetThreadPriority
             #5   0x92864964 in JVM_Send
             #6   0x9290114c in JNI_CreateJavaVM_Impl
             #7   0x928a51fc in JVM_GetClassMethodsCount
             #8   0x90021428 in _pthread_body
            
            Thread 8:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x9283ddf4 in JVM_NewInstance
             #3   0x92845d80 in JVM_ArrayCopy
             #4   0x9285d620 in JVM_MonitorNotify
             #5   0x9285e2f8 in JVM_MonitorWait
             #6   0x07766668 in 0x7766668
             #7   0x0776468c in 0x776468c
             #8   0x0776468c in 0x776468c
             #9   0xa2843c38 in typeinfo name for std::bad_exception
             #10  0x92838bdc in JVM_CurrentTimeMillis
             #11  0x92878c28 in JVM_FindClassFromClass
             #12  0x92892c90 in JVM_IsSameClassPackage
             #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
             #14  0x928787a0 in JVM_FindClassFromClass
             #15  0x928a51fc in JVM_GetClassMethodsCount
             #16  0x90021428 in _pthread_body
            
            Thread 9:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x9283ddf4 in JVM_NewInstance
             #3   0x92845d80 in JVM_ArrayCopy
             #4   0x9285d620 in JVM_MonitorNotify
             #5   0x9285e2f8 in JVM_MonitorWait
             #6   0x07766668 in 0x7766668
             #7   0x0776468c in 0x776468c
             #8   0x077645cc in 0x77645cc
             #9   0x077645cc in 0x77645cc
             #10  0xa2843c38 in typeinfo name for std::bad_exception
             #11  0x92838bdc in JVM_CurrentTimeMillis
             #12  0x92878c28 in JVM_FindClassFromClass
             #13  0x92892c90 in JVM_IsSameClassPackage
             #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
             #15  0x928787a0 in JVM_FindClassFromClass
             #16  0x928a51fc in JVM_GetClassMethodsCount
             #17  0x90021428 in _pthread_body
            
            Thread 10:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x9283de9c in JVM_NewInstance
             #3   0x92844e18 in JVM_GetClassLoader
             #4   0x92844ba4 in JVM_GetClassLoader
             #5   0x928a51fc in JVM_GetClassMethodsCount
             #6   0x90021428 in _pthread_body
            
            Thread 11:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x9283ddf4 in JVM_NewInstance
             #3   0x9285eb40 in JVM_FillInStackTrace
             #4   0x92903300 in JVM_InitProperties
             #5   0x92903138 in JVM_InitProperties
             #6   0x928787a0 in JVM_FindClassFromClass
             #7   0x928a51fc in JVM_GetClassMethodsCount
             #8   0x90021428 in _pthread_body
            
            Thread 12:
             #0   0x90074328 in mach_msg_trap
             #1   0x90006670 in mach_msg
             #2   0x9283ddf4 in JVM_NewInstance
             #3   0x9285eb40 in JVM_FillInStackTrace
             #4   0x9288890c in JVM_StartThread
             #5   0x92876c10 in JVM_FindLoadedClass
             #6   0x928787a0 in JVM_FindClassFromClass
             #7   0x928a51fc in JVM_GetClassMethodsCount
             #8   0x90021428 in _pthread_body
            
            PPC Thread State:
              srr0: 0x929ba640 srr1: 0x0000f030                vrsave: 0x00000000
               xer: 0x00000000   lr: 0x92857a38  ctr: 0x928498e0   mq: 0x00000000
                r0: 0x00000030   r1: 0xf0407a40   r2: 0x92857a38   r3: 0x6c1631d8
                r4: 0x6c1631d8   r5: 0x6c163200   r6: 0x00000000   r7: 0x0000000c
                r8: 0xa2833a58   r9: 0x00000000  r10: 0x00000008  r11: 0x00000b18
               r12: 0x928498e0  r13: 0xa282bd1c  r14: 0x00000000  r15: 0xf0407b90
               r16: 0xa28320f8  r17: 0x00000000  r18: 0x00160000  r19: 0xa282bd1c
               r20: 0xf0407b60  r21: 0xa282bd1c  r22: 0xa282bd1c  r23: 0xa282bd1c
               r24: 0xbfffaa5c  r25: 0x067d3940  r26: 0x00000000  r27: 0x00000000
               r28: 0xa28305b0  r29: 0x067ceb00  r30: 0x6c1631d8  r31: 0x9285bd1c

Comment 1

15 years ago
-> OJI?

WFM 2002082404/trunk/W2K
Assignee: asa → joe.chou
Severity: normal → critical
Component: Browser-General → OJI
Keywords: crash
QA Contact: asa → pmac

Comment 2

15 years ago
David, there was a problem with Mozilla, Java, and Mac OS X 10.2 reported as bug
154699. It was fixed after 8/15, which is the build you were using. I'm marking
this as a duplicate for now. Please retest using a newer build and feel free to
reopen if you still have this problem.

*** This bug has been marked as a duplicate of 154699 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Crash when entering this web site. → Crash when entering this web site

Comment 3

15 years ago
*** Bug 164563 has been marked as a duplicate of this bug. ***

Updated

15 years ago
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.