Closed Bug 1645687 Opened 3 months ago Closed 3 months ago

Quota meter in folder props has a too big border radius

Categories

(Thunderbird :: Theme, task)

Tracking

(thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(2 files, 1 obsolete file)

Attached image Quota.png

The in bug 841906 introduced quota meter styling uses a too big border radius. We have no other boxes with such a border radius and should use a standard of 2px.

With very low or very high quotas it's almost not visible because the radius hides too much, see screenshot for comparison.

Use 2px instead of 99px for the border radius.

[Approval Request Comment]
Regression caused by (bug #): Bug 841906
User impact if declined: Read comment 0
Testing completed (on c-c, etc.): soon on c-c
Risk to taking this patch (and alternatives if risky): no, only a CSS value change.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9156572 - Flags: review?(alessandro)
Attachment #9156572 - Flags: approval-comm-beta?
Comment on attachment 9156572 [details] [diff] [review]
1645687-quota-border-radius.patch

Review of attachment 9156572 [details] [diff] [review]:
-----------------------------------------------------------------

Sure, sounds good to me.
I proposed the fully rounded borders as I personally like them for progress bars since it creates a visual distinctions with input fields.
It's mostly a personal preference, so the issue you pointed out is very valid.
Thanks.

There's a typo in the commit message, can you update it with:  "Bug 1645687 - Use 2px border radius for the quota meter progress bar. r=aleca"
Attachment #9156572 - Flags: review?(alessandro) → review+

Fixed the commit message.

[Approval Request Comment]
Regression caused by (bug #): Bug 841906
User impact if declined: Read comment 0
Testing completed (on c-c, etc.): soon on c-c
Risk to taking this patch (and alternatives if risky): no, only a CSS value change.

Attachment #9156572 - Attachment is obsolete: true
Attachment #9156572 - Flags: approval-comm-beta?
Attachment #9156787 - Flags: review+
Attachment #9156787 - Flags: approval-comm-beta?
Target Milestone: --- → Thunderbird 79.0

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2d069be0478c
Use 2px border radius for the quota meter progress bar. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Comment on attachment 9156787 [details] [diff] [review]
1645687-quota-border-radius.patch

Approved for beta
Attachment #9156787 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.