Closed Bug 1645774 Opened 9 months ago Closed 9 months ago

Uncaught TypeError when clicking in sidebar of about:policies

Categories

(Firefox :: Enterprise Policies, defect, P5)

defect

Tracking

()

VERIFIED FIXED
Firefox 79
Tracking Status
firefox-esr78 --- verified
firefox79 --- verified

People

(Reporter: flod, Assigned: mkaply)

Details

Attachments

(1 file)

Clicking on one of the two available sections keeps raising errors in the console.

Uncaught TypeError: can't access property "textContent", button.children[1] is undefined
    show chrome://browser/content/policies/aboutPolicies.js:406
    onload chrome://browser/content/policies/aboutPolicies.js:366
    onload chrome://browser/content/policies/aboutPolicies.js:366
    EventHandlerNonNull* chrome://browser/content/policies/aboutPolicies.js:352

That's weird. I can't even figure out what this code is supposed to do.

Severity: -- → S4
Keywords: good-first-bug
Priority: -- → P5

I figured it out. Header switching isn't working. Should fix now.

Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Keywords: good-first-bug
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/9cb0de45cc86
Use proper textContent for section title. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

Comment on attachment 9156817 [details]
Bug 1645774 - Use proper textContent for section title. r?jaws

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Nice correctness fix, policy related
  • User impact if declined: UI problem in about:policies
  • Fix Landed on Version: 79
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just a visual change.
  • String or UUID changes made by this patch:
Attachment #9156817 - Flags: approval-mozilla-esr78?

Comment on attachment 9156817 [details]
Bug 1645774 - Use proper textContent for section title. r?jaws

Approved for 78.1esr.

Attachment #9156817 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
QA Whiteboard: [qa-79b-p2]

Reproduced the issue with Firefox 79.0a1 (20200615214838) on Windows 10x64.
The issue is verified fixed with Firefox 79.0 (20200720193547) and Firefox 78.1.0esr (20200702183914) from comment 9 on Windows 10x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.