Open Bug 1645916 Opened 1 year ago Updated 1 year ago

[macOS] Click event doesn't move focus on focusable recipient pill

Categories

(Thunderbird :: General, defect)

Unspecified
macOS
defect

Tracking

(thunderbird_esr68 unaffected, thunderbird_esr78 affected)

Tracking Status
thunderbird_esr68 --- unaffected
thunderbird_esr78 --- affected

People

(Reporter: aleca, Unassigned)

References

Details

(Keywords: access, ux-consistency, ux-efficiency)

This is a follow up to bug 1645643 in order to dive deeper on this issue.

On Windows and Linux, clicking on a pill moves the focus on it automatically.
This doesn't happen on macOS and we're forced to use a pill.focus() in order to overcome this issue.

The pill is a Custom Element with allowevents attribute.
I tried also adding a tabindex and role="button" attribute, but the focus still doesn't automatically move.

I also tried changing the accessibility.tabfocus preference without success as that affects only the keyboard focus ring.

Is this a platform issue that can be fixed with a specific setting like the accessibility.tabfocus?
Is this a problem with Custom Elements?

We should dive deeper into this issue to be sure is not affecting other Custom Elements and causing accessibility issues.

I'm not pinging anyone from m-c yet as I'm not sure if this is a known issue which I couldn't find in a previous bug.

Version: unspecified → 78
You need to log in before you can comment on or make changes to this bug.