Better Colors for ToDo Task (completed, overdue, current, due today, and future)

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: Peter Lairo, Assigned: Mike Potter)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
This is a spinoff from bug 155875 to request the color codes be more
differentiated and therefore much more recognizable and useful.

+----------------------+----------------------+---------------------+
| TASK IS              | BUILD 2002082311     | SUGGESTED COLOR     |
+----------------------+----------------------+---------------------+
| Completed            | BLACK and STRIKEOUT  | BLACK and STRIKEOUT |
| Overdue              | RED                  | RED                 |
| Due today            | RED                  | MAGENTA (or Orange) | <- NEW
| Started (not yet due)| GREEN                | GREEN               |
| NOT Started (future) | BLACK                | BLUE                | <- NEW
+----------------------+----------------------+---------------------+
(Reporter)

Comment 1

16 years ago
Created attachment 96668 [details]
Screenshot showing how colors help quickly identify a task's status
(Assignee)

Comment 2

16 years ago
OK, this is done in CVS to what I think they should be.
I've added blue for items that are due today, and black remains for items that
are due in the future, and that have not yet started.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

16 years ago
By the way, if you don't like the colors, you can customize them by looking in
the calendar.css files in modern/ or classic/
You're looking for the string "overdue" to see how we get the red in there.
You can customize the blue and red to whatever color you want.
(Reporter)

Comment 4

16 years ago
I think BLACK for tasks that are in the _future_ AND _completed_ is highly
contradictory (even if the completed tasks are also striked-out).

BLUE is too "peaceful" a color for Tasks that are due today (those are important
tasks). A more "urgent" color (magenta?) would be better here.

PS. Nobody will change the default colors. That is why the defaults need to be
as perfect as possible.
(Assignee)

Comment 5

16 years ago
What is the hex value for "magenta"?
(Reporter)

Comment 6

16 years ago
I think magenta is red with some blue in it. Try R:200, G:30, B:50. :)

I any event, the color should look reddish, but be distinguishable from the red
of overdue events (dark orange?).

Ah, I'll get a screenshot of magenta...
(Reporter)

Comment 7

16 years ago
Created attachment 96717 [details]
VOILA - Magenta (from OpenOffice Draw)
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: colint → sunbird
You need to log in before you can comment on or make changes to this bug.