Closed Bug 164599 Opened 19 years ago Closed 12 years ago

Week and day "planner" calendar views [extension fodder]

Categories

(Calendar :: Calendar Frontend, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Peter, Unassigned)

References

Details

(Whiteboard: [extension fodder])

Attachments

(4 files)

Mozilla Calendar 2002082311-cal

The week and day views really should NOT be a timeline. That just wastes a lot
of vertical space and severly limits the horizontal space. Better would be for
each day to list the Appointments, Events, Anniversaries, Tasks and Calls. 

Perhaps the user could set a preference whether he wants appointsments to be
above or below the other items. 

Here's an example:

MONDAY (26.05.2525)           <or>  MONDAY (26.05.2525)
------------------------------     -------------------------------
Appointments    14:30 Dentist      Events          Vacation
                19:00 Party        Anniversaries   Mom's Birthday
------------------------------     Tasks           Buy Flowers
Events          Vacation                           Get Haircut
Anniversaries   Mom's Birthday     Calls           Call Mom
Tasks           Buy Flowers        -------------------------------
                Get Haircut        Appointments    14:30 Dentist
Calls           Call Mom                           19:00 Party
------------------------------     -------------------------------
ASCII Art of how Week View should look:

+-----------------------------------------------------------------------+
| AUGUST 2002                      | |          AUGUST - September 2002 |
|----------------------------------| |----------------------------------|
| 26 Monday |||||||||||||||||||||||| |                      Thursday 29 |
|----------------------------------| |----------------------------------|
|                                  |=|                                  |
|                                  |=|                                  |
|                                  | |                                  |
|                                  | |                                  |
|                                  | |                                  |
|----------------------------------| |----------------------------------|
| 27 Tuesday                       | |                        Friday 30 |
|----------------------------------| |----------------------------------|
|                                  | |                                  |
|                                  | |                                  |
|                                  |=|                                  |
|                                  |=|                                  |
|                                  | |                                  |
|                                  | |                                  |
|----------------------------------| |----------------------------------|
| 28 Wednesday                     | |                      Saturday 31 |
|----------------------------------| |----------------------------------|
|                                  | |                                  |
|                                  | |                                  |
|                                  | |----------------------------------|
|                                  |=|                         Sunday 1 |
|                                  |=|----------------------------------|
|                                  | |                                  |
|----------------------------------| |----------------------------------|
| [ Select Display Type \/ ]       | |             Week 35              |
+-----------------------------------------------------------------------+

Note that this method significantly increases the amount of horizontal space to
the descriptions of events, tasks, etc. as compared to the current implementation.
Note how the current date is clearly identifieable by marking it RED.
Suggested DAY VIEW:

+-----------------------------------------------------------------------+
| Monday 26            AUGUST 2002 | | Tuesday 27           AUGUST 2002 |
|----------------------------------| |----------------------------------|
| All-Day Events,                  | |//// VACATION - GREECE ///////////|
| Tasks,                           | | Finish Project X                 |
| Calls,                           |=| (123) 123 1234 - Jon Doe (Call)  |
| Anniversaries,                   |=| Aunt Rosie's Birthday            |
| ... all go here                  | |                                  |
|                                  | |                                  |
|---------------^-----------------°| |---------------^-----------------°|
|8:00  |                           | |8:00  |                           |
|      |                           | |      |                           |
|----------------------------------| |----------------------------------|
|9:00  |                           | |9:00  | +-----------------------+ |
|      |                           | |      | | Board Meeting         | |
|----------------------------------| |--------| (i wished ;) )        |-|
|10:00 |                           |=|10:00 | |                       | |
|      |                           |=|      | |                       | |
|----------------------------------| |--------|                       |-|
|11:00 |                           | |11:00 | +-----------------------+ |
|      |                           | |      |                           |
|----------------------------------| |----------------------------------|
|12:00 |                           | |12:00 |                           |
|      |                           | |      |                           |
|----------------------------------| |----------------------------------|
|13:00 |                           | |13:00 |                           |
|      |                           | |      |                           |
|----------------------------------| |----------------------------------|
|14:00 |                           |=|14:00 |                           |
|      |                           |=|      |                           |
|----------------------------------| |----------------------------------|
|---------------v------------------| |-----------------v----------------|
| <<<  [ Select Display Type \/ ]  | | 239th day (126 days left)    >>> |
+-----------------------------------------------------------------------+

Notice how this implemention allows for far more information content than the
current implementation:
- tasks, call, anniversaries and all-day events are shown
- two days are seen (ideally, "today" would ALWAYS be on the LEFT)
- day-of-year number
This is almost a duplicate of bug 157271, which is really the need for custom views.
I don't think we'll be able to make a calendar that can satisfy everyone, so the
views should be able to be made easily and interchangeably.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
*** Bug 166619 has been marked as a duplicate of this bug. ***
*** Bug 199782 has been marked as a duplicate of this bug. ***
I would have to disagree with Mike Potter's comment. People have different preferences, but the default solution should be one which satisfies some basic requirements. Even if it is not exactly what people would like, if it satisfies these requirements, it will be useable.Currently, the view does not satisfy these requirements:- A day with few events that occur outside office hours should be displayed without scrolling.- A week view should display data without scrolling when there are only a couple of items per day.The proposed changes satisfy this requirement. If outlook and notes can survive without customizable views of weeks, I'm sure mozilla calendar can too -- they just chose sensible default settings, that's all.I would just ditch the current view. It's not so much a question of taste, but of useability. I would not go down the path just yet of going down the rabbit-hole of "custom plugin views" etc. -- this will mean it will never get fixed.
The odds of it getting fixed now are low anyways.
I agree that the week view needs improvement.
Assignee: mikep → nobody
*** Bug 207341 has been marked as a duplicate of this bug. ***
IMHO, both present week view and suggested week view are useful, depending on
situation.  It would be nice to add the suggested week view without canceling
the present one.
(In reply to comment #11)
> IMHO, both present week view and suggested week view are useful, depending on
> situation.  It would be nice to add the suggested week view without canceling
> the present one.

agreed. Always lean towards adding more options rather than simply making things
different.
Depends on: 165505
I think this is a wrong dependency... Why is an export of a todo list dependant
on the week/day views
(In reply to comment #13)
> I think this is a wrong dependency... Why is an export of a todo list dependant
> on the week/day views

Export? Where and how did you see it's an export?
Bug 164599 depends on:  Bug 165505  	 

is how.  (adding dependancy person to the CC list, hope they'll notice)
QA Contact: colint → sunbird
I'm not sure if it's still valid. Can it be closed?
To reproduce in sunbird 0.3a2:

Create a single event from 7pm-9pm "Dinner with Friends"

Click on day view. It's invisible.
Click on week view. It's invisible.
Click on multiweek view. Yes! I can see it.

In day and week view, all of my screen real estate is being taken up by non-appointments. There's no indication I need to scroll on that particular day so I don't.

I have a 1240x768 screen. I have enough screen real estate to display this very boring social life without scrolling my screen. Outlook 97 can.

This bug's now celebrating its 5-year anniversary. :-) In my view, it's critical to making Sunbird an outlook killer like firefox is an ie killer.
(In reply to comment #17)
Using Sunbird/0.6a1 (20070118) I can see the created event in all four views displayed at correct date and time -> Worksforme. If your issue is just about scrolling there are plenty other bugs that are being worked on to improve this situation.

But the original bug report is an enhancement request about completely changing the day/week view from time-line style to something similar to the current weekly print layout. This is the topic that needs to be discussed.
Changing the summary to reflect that.

I'm marking this as an enhancement.

To me, it's extension fodder.
Severity: normal → enhancement
Keywords: helpwanted
Summary: Week and Day Views need improvement → Want week and day "planner" views
I would like to emphasize the usefulness of having a week view with the days on two rows ("week planner").
This view should be provided in addition to the existing week view, and should not replace it.

Some reasons for implementing the new view:
- this view is one of the four views provided by Microsoft Outlook (see image attached "Screenshot of week view in Microsoft Outlook 2003").
Considering the high diffusion of Microsoft Outlook, this view would probably be appreciated by a large number of users
- this view would be particularly useful to display a work calendar
- this view is the same used for printing from Sunbird using the Weekly Planner layout

In order to assure a proper localization, the two consecutive days that occupy half the space (Saturday and Sunday for several countries) should be chosen by the end user, creating a new option in the Preferences > Views panel.
The default days could be set as Saturday and Sunday, depending on the locale (if possible).
Just to mention that the "week planner" view is provided also by IBM Lotus Notes 7 calendar (see the screenshot attached). The consideration done for Microsoft Outlook in comment #21 is valid also for Lotus Notes.
Component: Sunbird Only → Calendar Views
QA Contact: sunbird → views
Flags: wanted-calendar0.8?
Setting wanted0.8- as the main Calendar developers will not devote any time to
this in the 0.8 timeframe. Patches are, of course, always welcome.
Flags: wanted-calendar0.8? → wanted-calendar0.8-
Requesting for calendar 1.0, because the week-view should be more usable.
Flags: wanted-calendar1.0?
No longer depends on: 165505
Flags: wanted-calendar0.8-
Summary: Want week and day "planner" views → Week and day "planner" calendar views
Do we really want to change our week/day views to look like all the other apps? What I find nice about our application is that you can quickly see where you have time in the week and its easy to create events via dragging.

I'd vote to WONTFIX this in favor of creating an extension, now that bug 489590 is fixed.
I don't think this bug is about changing the view to week/day but ADD a week/day view, as this bug is marked as an Enhancement.

About making this app to look like all the other apps... Well, personally I don't feel it's a problem copying others' ideas (actually, in IT, we are learnt NOT to reinvent the fire/wheel, no?), especially others have actually copied the "idea" from agenda in paper form.

I won't vote WONTFIX.
In that case I think it should be an extension even more. The week view we have is a sensible default, if people need a planner type week view, then they can easily install the extension, assuming it exists. The status WONTFIX is not to say this extension shouldn't be created, just to say that this won't be a part of the core product.
(In reply to comment #28)
> In that case I think it should be an extension even more.

Well, I don't see why.  Because it's an "enhancement" that it should be an extension?  If that's the reason, better call Bugzilla team to remove the "enhancement" from the "Importance" field and tell everybody that from now on, no more enhancement is allowed as they are all forced to be implemented as extension...

> The week view we have
> is a sensible default, if people need a planner type week view, then they can
> easily install the extension, assuming it exists. The status WONTFIX is not to
> say this extension shouldn't be created, just to say that this won't be a part
> of the core product.

In pragmatical view-point:
* I don't care whether it's an extension or not, as long as it gives me the function.
* Whether it's easy to install or not is another discussion.  It's not easy to find an extension if you have no idea such function exists, or if you have no idea what keywords to use.

In theoretical view-point:
extension are written in JavaScript, so they're parsed and interpreted.  Thus they're run more slowly than native code.  That's quite unfair to those users who need/use this planner a lot.  Well, unless even the default week view is also written as an extension, then I have nothing to say.

And more importantly: it's not sure if such extension will ever be created.  I won't vote anything while there's no alternative.
(In reply to comment #29)
> (In reply to comment #28)
> > In that case I think it should be an extension even more.
> 
> Well, I don't see why. 
No, because I don't think it makes sense to have two week views in the core application. If we start with this, why not another month view and another day view? The application will get bloated. This has nothing to do with bugzilla, please don't be sarcastic :-)

> * Whether it's easy to install or not is another discussion.  It's not easy to
> find an extension if you have no idea such function exists, or if you have no
> idea what keywords to use.
If you are not happy with the core functions, then you might click on addons, then search for "view". If the extension author puts "view" into the extension title, then everything should be fine.

> In theoretical view-point:
> extension are written in JavaScript, so they're parsed and interpreted.  Thus
> they're run more slowly than native code.  That's quite unfair to those users
> who need/use this planner a lot.  Well, unless even the default week view is
> also written as an extension, then I have nothing to say.
All views are written in javascript, as is most other calendar code. The fact that it is an extension doesn't decrease performance.

> And more importantly: it's not sure if such extension will ever be created.  I
> won't vote anything while there's no alternative.
So you have two options here: not being sure if this extension will be created, or not being sure if we ever have time for this as a core feature. Sorry.
Not to be taken personally, but one week view is enough. If extension visibility is a problem, then this should be solved in a different bug (i.e for the extension manager itself, or maybe AMO has a good way to solve this, ...).
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: wanted-calendar1.0?
Resolution: --- → WONTFIX
Summary: Week and day "planner" calendar views → Week and day "planner" calendar views [extension fodder]
Whiteboard: [extension fodder]
You need to log in before you can comment on or make changes to this bug.