Closed Bug 1646261 Opened 1 year ago Closed 1 year ago

Investigate multiple reflow behaviour in geckoview-junit

Categories

(Core :: Panning and Zooming, task, P3)

Unspecified
Android
task

Tracking

()

RESOLVED INVALID

People

(Reporter: kats, Unassigned)

References

Details

While working on a patch for bug 1645954 I discovered that the code here triggers multiple ResizeReflow calls on the top-level presShell, and with different sizes. This happens (as far as I can tell) only on Android, and can be seen when running the geckoview-junit tests.

This seems undesirable for performance reasons if nothing else. This bug is to investigate why that's happening. Once the patches for bug 1645954 land, it can be reproduced by removing the ifdef guard around the AutoResizeReflowSquasher those patches add to BrowserChild::RecvUpdateDimensions, and running the geckoview-junit suite.

The whole resize reflow stuff with the mobile viewport manager is pretty messy... The reason why eDelayResize didn't work in that bug is because MVM ignores the SuppressReflow flag here (but I think it needs to, because it needs to actually reflow to figure out the right CSS viewport...).

Also tangential to this bug but writing it down so I don't forget. Emilio mentioned on Matrix that this code seems very similar to the code that currently has the AutoResizeReflowSquasher and so might need one too.

This is made obsolete by emilio's patches in bug 1647871.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
See Also: → 1647871
You need to log in before you can comment on or make changes to this bug.