Closed Bug 1646414 Opened 2 years ago Closed 14 days ago

Crash in [@ mozilla::dom::ChildSHistory::Go]

Categories

(Core :: DOM: Navigation, defect, P3)

Unspecified
All
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- disabled
firefox80 --- disabled
firefox81 --- disabled
firefox82 --- ?
firefox83 --- wontfix

People

(Reporter: sg, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-1c8d434c-3154-4b2a-b33e-992020200617.

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::ChildSHistory::Go docshell/shistory/ChildSHistory.cpp:73
1 xul.dll mozilla::dom::ChildSHistory::PendingAsyncHistoryNavigation::Run docshell/shistory/ChildSHistory.h:97
2 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1234
3 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:501
4 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:87
5 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
6 xul.dll MessageLoop::Run ipc/chromium/src/base/message_loop.cc:290
7 xul.dll nsBaseAppShell::Run widget/nsBaseAppShell.cpp:137
8 xul.dll nsAppShell::Run widget/windows/nsAppShell.cpp:430
9 xul.dll XRE_RunAppShell toolkit/xre/nsEmbedFunctions.cpp:913

This happens since Bug 1515073 landed with build id 20200609151649 in code that was newly added there.

Flags: needinfo?(jhofmann)

Set release status flags based on info from the regressing bug 1515073

Also disabled in nightly since bug 1652452.

Blocking back button intervention meta bug 1645211.

S3 because crash volume is low for now.

Blocks: 1645211
Severity: -- → S3
Priority: -- → P3

This might be regressed by bug 1515073 but it’s happening with the pref off, too, so I don’t think we should track this against the meta bug.

I’m not sure I can get to looking at this very low volume crash, I don’t have an idea about if off-hand but I can continue to keep an eye on it.

No longer blocks: 1645211
Flags: needinfo?(jhofmann)
Has Regression Range: --- → yes

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 14 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.