Closed Bug 1646593 Opened 7 months ago Closed 7 months ago

Perma [tier 2] /html/cross-origin-opener-policy/reporting-popup-same-origin.https.html | coop reporting test reporting-same-origin_to_CROSS_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_ - promise_test: Unhandled rejection with value: "No rep

Categories

(Testing :: web-platform-tests, defect, P5)

defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=306701315&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/K3gMSqZASkqx4DHRFnOumg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-06-18T00:18:12.189Z] 00:18:12     INFO - TEST-START | /css/css-counter-styles/idlharness.html
[task 2020-06-18T00:18:12.237Z] 00:18:12     INFO - Setting pref dom.animations-api.compositing.enabled (true)
[task 2020-06-18T00:18:12.279Z] 00:18:12     INFO - Setting pref layout.css.comparison-functions.enabled (true)
[task 2020-06-18T00:18:13.456Z] 00:18:13     INFO - .....................................
[task 2020-06-18T00:18:13.456Z] 00:18:13     INFO - TEST-OK | /css/css-counter-styles/idlharness.html | took 1265ms
[task 2020-06-18T00:18:13.456Z] 00:18:13     INFO - Restarting browser for new test group
[task 2020-06-18T00:18:13.481Z] 00:18:13     INFO - PID 6372 | 1592439493479	Marionette	INFO	Stopped listening on port 52313
[task 2020-06-18T00:18:13.789Z] 00:18:13     INFO - PID 6372 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:13.955Z] 00:18:13     INFO - PID 6372 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:13.956Z] 00:18:13     INFO - PID 6372 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:13.956Z] 00:18:13     INFO - PID 6372 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:13.956Z] 00:18:13     INFO - PID 6372 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:13.975Z] 00:18:13     INFO - PID 6372 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:14.484Z] 00:18:14     INFO - PID 6372 | ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:29.590Z] 00:18:29     INFO - 
[task 2020-06-18T00:18:29.590Z] 00:18:29     INFO - TEST-FAIL | /html/cross-origin-opener-policy/reporting-popup-same-origin.https.html | coop reporting test reporting-same-origin_to_CROSS_ORIGIN_same-origin--report-to--coop-popup-report-endpoint-_ - promise_test: Unhandled rejection with value: "No report matched the expected report for endpoint: coop-popup-report-endpoint, expected report: {\"body\":{\"disposition\":\"enforce\",\"document-uri\":\"/coop-coep.py?.*channel=reporting-same-origin_to_CROSS_ORIGIN_same-origin--report-to--coop-popup-report-endpoint-_$/\",\"effective-policy\":\"same-origin\",\"navigation-uri\":\"https://web-platform.test:8443/html/cross-origin-opener-policy/reporting-popup-same-origin.https.html\",\"violation-type\":\"navigation-to-document\"},\"url\":\"/coop-coep.py?.*channel=reporting-same-origin_to_CROSS_ORIGIN_same-origin--report-to--coop-popup-report-endpoint-_$/\",\"type\":\"coop\"}, within available reports: []"
[task 2020-06-18T00:18:29.590Z] 00:18:29     INFO - TEST-FAIL | /html/cross-origin-opener-policy/reporting-popup-same-origin.https.html | coop reporting test reporting-same-origin_to_SAME_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_ - promise_test: Unhandled rejection with value: "No report matched the expected report for endpoint: coop-popup-report-endpoint, expected report: {\"body\":{\"disposition\":\"enforce\",\"document-uri\":\"/coop-coep.py?.*channel=reporting-same-origin_to_SAME_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_$/\",\"effective-policy\":\"unsafe-none\",\"navigation-uri\":\"https://web-platform.test:8443/html/cross-origin-opener-policy/reporting-popup-same-origin.https.html\",\"violation-type\":\"navigation-to-document\"},\"url\":\"/coop-coep.py?.*channel=reporting-same-origin_to_SAME_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_$/\",\"type\":\"coop\"}, within available reports: []"
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - TEST-UNEXPECTED-FAIL | /html/cross-origin-opener-policy/reporting-popup-same-origin.https.html | coop reporting test reporting-same-origin_to_CROSS_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_ - promise_test: Unhandled rejection with value: "No report matched the expected report for endpoint: coop-popup-report-endpoint, expected report: {\"body\":{\"disposition\":\"enforce\",\"document-uri\":\"/coop-coep.py?.*channel=reporting-same-origin_to_CROSS_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_$/\",\"effective-policy\":\"unsafe-none\",\"navigation-uri\":\"https://web-platform.test:8443/html/cross-origin-opener-policy/reporting-popup-same-origin.https.html\",\"violation-type\":\"navigation-to-document\"},\"url\":\"/coop-coep.py?.*channel=reporting-same-origin_to_CROSS_ORIGIN_unsafe-none--report-to--coop-popup-report-endpoint-_$/\",\"type\":\"coop\"}, within available reports: []"
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - TEST-INFO | expected TIMEOUT
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - 
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - TEST-UNEXPECTED-PASS | /html/cross-origin-opener-policy/reporting-popup-same-origin.https.html | verify remaining reports - expected NOTRUN
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - TEST-INFO | expected NOTRUN
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - TEST-UNEXPECTED-OK | /html/cross-origin-opener-policy/reporting-popup-same-origin.https.html | expected TIMEOUT
[task 2020-06-18T00:18:29.591Z] 00:18:29     INFO - TEST-INFO expected TIMEOUT | took 93530ms
[task 2020-06-18T00:18:29.621Z] 00:18:29     INFO - PID 1840 | 1592439509614	Marionette	INFO	Stopped listening on port 51231
[task 2020-06-18T00:18:29.902Z] 00:18:29     INFO - PID 1840 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:30.546Z] 00:18:30     INFO - PID 1840 | ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T00:18:34.388Z] 00:18:34     INFO - Browser exited with return code 0
[task 2020-06-18T00:18:34.389Z] 00:18:34     INFO - PROCESS LEAKS None
[task 2020-06-18T00:18:34.390Z] 00:18:34     INFO - Closing logging queue
[task 2020-06-18T00:18:34.390Z] 00:18:34     INFO - queue closed
[task 2020-06-18T00:18:34.455Z] 00:18:34     INFO - Application command: Z:\task_1592436367\build\application\firefox\firefox.exe -marionette about:blank --wait-for-browser -profile c:\users\task_1592436367\appdata\local\temp\tmpobmbwa
[task 2020-06-18T00:18:34.460Z] 00:18:34     INFO - Starting runner
[task 2020-06-18T00:18:38.740Z] 00:18:38     INFO - PID 11176 | console.error: SearchCache: "_readCacheFile: Error reading cache file:" (new Error("", "(unknown module)"))
[task 2020-06-18T00:18:41.490Z] 00:18:41     INFO - PID 11176 | 1592439521481	Marionette	INFO	Listening on port 52359
[task 2020-06-18T00:18:42.707Z] 00:18:42     INFO - TEST-START | /_mozilla/dom/classList.html

James,
Could you please take a look, I believe it's caused by the last wpt-sync push.

Flags: needinfo?(james)
Assignee: nobody → james
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.