Closed Bug 1646640 Opened 11 months ago Closed 7 months ago

Investigate if shared stylesheet cache needs to be partitioned

Categories

(Core :: Privacy: Anti-Tracking, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1645987

People

(Reporter: baku, Unassigned)

References

(Blocks 1 open bug)

Details

https://searchfox.org/mozilla-central/rev/eef39502e08bcd3c40573c65a6827828dce4a032/layout/style/SharedStyleSheetCache.h

SharedStyleSheetCache is a component that allows the sharing of stylesheet cross documents. We probably need to isolate this cache using the partitioned principal.

We probably need to change this line: https://searchfox.org/mozilla-central/rev/eef39502e08bcd3c40573c65a6827828dce4a032/layout/style/Loader.cpp#1925

Duplicate of bug 1645987?

Severity: -- → N/A
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1645987
You need to log in before you can comment on or make changes to this bug.