Closed Bug 1646795 Opened 3 months ago Closed 3 months ago

Synced tabs expire after a week?

Categories

(Firefox :: Sync, task, P3)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: mozilla, Unassigned)

References

()

Details

A user on the support forums has brought up a potential concern about the fact that Firefox Sync deletes synced tabs after one week. They would like that point to be added to the current documentation that's on the support forum KB pages about Firefox Sync.

It's a fair point. I don't sync tabs with Firefox Sync, so I was just curious if someone else can confirm that this is indeed the fact.

If so, I will discuss adding it to the KB with the reviewers there and I would recommend that some documentation be added to the Firefox Sync UI about it.

Component: General → Sync
Priority: -- → P3
Product: Cloud Services → Firefox

Thanks Wesley! I agree with the comment here that this should no longer be the case on Desktop thanks to Bug 1573758, and we would expect synced tabs to be kept around much longer than a week.

I just checked and it looks like the same change was not applied to Firefox for iOS, on which the tabs still expire after 21 days. I've filed an issue here to track that.

I don't know what the expiry is for tabs saved from Firefox for Android, but I wouldn't be surprised to find that it's limited to a few weeks.

It may also be that a user's synced tabs disappear or are hidden for reasons other than deliberate expiry - for example if their device gets disconnected from their Firefox Account then I believe our clients will ignore any synced tabs stored by the now-unknown device. or if they hit one of the several reasons for being moved to a new storage node.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
See Also: → 1573758

(Whoops accidentally submitted before this final comment, so adding for completeness...)

Overall I think it's fair to say that this expiry behaviour is a bug from legacy system requirements, not an intended feature. Given that, I don't think there's anything actionable we can add to the UX, and will close this bug in favour of the above-linked ones.

Thank you very much for the information, Ryan.

You need to log in before you can comment on or make changes to this bug.