Closed Bug 1646829 Opened 2 years ago Closed 2 years ago

Create a New nsIPrinter XPIDL Interface and Implementation

Categories

(Core :: Printing: Setup, enhancement, P1)

79 Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1647480
Tracking Status
firefox79 --- wontfix
firefox80 --- fixed

People

(Reporter: nordzilla, Assigned: nordzilla)

References

Details

Attachments

(1 obsolete file)

The scope of this patch will be to create the initial XPIDL interface and implementation for nsIPrinter, providing a single name attribute for now.

The overall goal is to continue to flesh out this interface over time.

  • Add new interface for nsIPrinter.
  • Add readonly attribute for printer name.
  • Add implementation of interface: nsPrinterImpl.
Attachment #9158348 - Attachment description: Bug 1646829 - Add nsIPrinter XPIDL Interface → Bug 1646829 - Add nsIPrinter XPIDL Interface r=jwatt
Severity: -- → S3
Priority: -- → P1
Blocks: 1647480

Comment on attachment 9158348 [details]
Bug 1646829 - Add nsIPrinter XPIDL Interface r=jwatt

Revision D80548 was moved to bug 1647480. Setting attachment 9158348 [details] to obsolete.

Attachment #9158348 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1647480
No longer blocks: 1647851
Whiteboard: print2020_v79
You need to log in before you can comment on or make changes to this bug.