Closed Bug 1646837 Opened 3 months ago Closed 3 months ago

Crash in [@ nsAbLDIFService::AddLdifRowToDatabase]

Categories

(Thunderbird :: General, defect)

Unspecified
Windows 10
defect

Tracking

(thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 --- fixed

People

(Reporter: wsmwk, Assigned: mkmelin)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-39854da4-4463-4b19-a2e8-5cabf0200618.

Top 10 frames of crashing thread:

0 xul.dll nsAbLDIFService::AddLdifRowToDatabase comm/mailnews/addrbook/src/nsAbLDIFService.cpp:386
1 xul.dll nsAbLDIFService::ImportLDIFFile comm/mailnews/addrbook/src/nsAbLDIFService.cpp:130
2 xul.dll ImportAddressImpl::ImportAddressBook comm/mailnews/import/text/src/nsTextImport.cpp:408
3 xul.dll nsImportGenericAddressBooks::BeginImport comm/mailnews/import/src/nsImportAddressBooks.cpp:437
4 xul.dll XPTC__InvokebyIndex 
5  @0x22563e99a3f 
6 xul.dll truncf 
7 xul.dll truncf 
8 xul.dll static XPCWrappedNative::CallMethod js/xpconnect/src/XPCWrappedNative.cpp:1140
9 xul.dll XPC_WN_CallMethod js/xpconnect/src/XPCWrappedNativeJSOps.cpp:946

Looks like outlist was null

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9157770 - Flags: review?(benc)
Comment on attachment 9157770 [details] [diff] [review]
bug1646837_abldifservice_crash.patch

Review of attachment 9157770 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like it'll stop it crashing, so r+.
But, isn't it confusing to the user that the import looks like it's worked, but does nothing?
I get that this is probably a pretty niche issue, but it'd be nice to flag it up with a note or something.
So if anyone does any future work in this code it'll occur to them to propagate the error back out to the importLDIFFile() caller.
Attachment #9157770 - Flags: review?(benc) → review+

Yeah ideally this wouldn't be a void method... many of the error cases are unlikely though, so it's unclear if you're already not in bigger problems.

Target Milestone: --- → Thunderbird 79.0

(In reply to Magnus Melin [:mkmelin] from comment #3)

Yeah ideally this wouldn't be a void method... many of the error cases are unlikely though, so it's unclear if you're already not in bigger problems.

That's what I figured. One to punt onward for the next time someone's wading about in this code :-)

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/9a572242446d
fix Crash in [@ nsAbLDIFService::AddLdifRowToDatabase]. r=benc

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Comment on attachment 9157770 [details] [diff] [review]
bug1646837_abldifservice_crash.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #9157770 - Flags: approval-comm-beta?
Comment on attachment 9157770 [details] [diff] [review]
bug1646837_abldifservice_crash.patch

Approved for beta
Attachment #9157770 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.