Closed Bug 1646955 Opened 3 months ago Closed 3 months ago

Ubuntu/Lockwise - Hide additional separator if no import/export options are available

Categories

(Firefox :: about:logins, defect, P1)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- verified
firefox77 --- unaffected
firefox78 --- verified
firefox79 --- unaffected

People

(Reporter: csasca, Assigned: MattN)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Additional separator

Affected versions

  • Firefox 78.0b9

Affected platforms

  • Ubuntu 20.04 & 18.04

Steps to reproduce

  1. Launch Firefox
  2. Access about:logins
  3. Click on the three dots in the upper right part of the screen

Expected result

  • The dropdown has no additional separator if no Import/Export options are listed in it.

Actual result

  • The dropdown has an additional separator.

Regression range

  • Will see for one if this is not intended. It seems that for example that Firefox 76.0b5 does not have that additional separator.

Additional notes

  • This may be intended, as I saw that in nightly, there is a feature for Ubuntu to add export logins option.
Has STR: --- → yes
Summary: Ubuntu/Lockwise - Hide additional separator if no import/export options available → Ubuntu/Lockwise - Hide additional separator if no import/export options are available
Attachment #9157903 - Attachment filename: Additional separator → Additional separator.png
Attachment #9157903 - Attachment mime type: application/octet-stream → image/png

The separator should have been hidden with the export item for Beta.

Assignee: nobody → MattN+bmo
Severity: normal → S3
Status: NEW → ASSIGNED
Type: enhancement → defect
Keywords: regression
Priority: -- → P1
Regressed by: 249801

The export item is hidden in Fx78.

Comment on attachment 9158255 [details]
Bug 1646955 - about:logins: Hide new menu separator added for export. r=severin

Beta/Release Uplift Approval Request

  • User impact if declined: Ugly separator above the about:logins menu items on Linux
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simply adding the hidden attribute on the separator to match the Export option
  • String changes made/needed: None
Attachment #9158255 - Flags: approval-mozilla-beta?

Comment on attachment 9158255 [details]
Bug 1646955 - about:logins: Hide new menu separator added for export. r=severin

approved for 78 rc1

Attachment #9158255 - Flags: approval-mozilla-beta? → approval-mozilla-release+

Verified on Firefox 78.0 under Ubuntu 20.04 and the separator is no longer there. Also, shouldn't this be marked as Resolved Fixed?

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78

Verified with a 78.0esr build from treeherder (20200623151414) and it seems to be fixed there as well.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.