Closed Bug 1646982 Opened 2 years ago Closed 4 months ago

Update NotificationBox API usage once it supports Fluent translations directly

Categories

(Thunderbird :: General, task)

Tracking

(thunderbird_esr91 wontfix)

RESOLVED FIXED
96 Branch
Tracking Status
thunderbird_esr91 --- wontfix

People

(Reporter: lasana, Assigned: mkmelin)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0

Type: enhancement → task
Depends on: 1646160
See Also: → 1629360
Component: Untriaged → General

I have a cleaner approach for this and we can simplify our code while we wait for the toolkit support.

Assignee: nobody → alessandro
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Leaving this open since we still want to update our notifications in case something changes in bug 1646160

Target Milestone: --- → 96 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fae98937d3eb
Stop using createDocumentFragment to add fluent strings to notifications. r=mkmelin

Removing this from my list of assigned bugs till we wait for m-c to change things around

Assignee: alessandro → nobody
Status: ASSIGNED → NEW

Bug 1646160, which is great news as it allows us to clean up our usage of the notificationbox.
I can take care of this tomorrow if no one wants to jump on it.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED

I had the c-c fix for the above in my queue. Just waited for m-c to land. I suppose there may be other cases out there though. We can always clean them up later as we find them.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9b081c285a52
use Fluent for notificationbox label. r=lasana
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Keywords: leave-open
Resolution: --- → FIXED
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/829ee7bd4805
follow-up - fix linting. rs=eslint DONTBUILD
You need to log in before you can comment on or make changes to this bug.