If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Stylesheet guide is NOT bein correctly supported.

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: tom.williams, Assigned: dbaron)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020826

Various things like text appearing as a grey color when the stylesheet indicates
it should be white and white vertical separator bars are NOT appearing in the
page menu header when they should.  General incorrect rendering of the Captaris
home page b based on the stylesheet info reerenced by the page.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.captaris.com/
2.The text in the menu header should be white and there should be white vertical
separator bars in the "Solutions" line.
3.

Actual Results:  
The text that should be white is grey and NO vertical separator bars appear.

Expected Results:  
The text that should be white should appear white and there SHOULD be vertical
separator bars in the "Solutions" line.

This page renders correctly in IE 4+.
(Reporter)

Comment 1

15 years ago
Here is some sample HTML and styelsheet info that illustrate the problem:

HTML snipet:

<td width="100%" nowrap class="text11WtB"><b>Unified Communications 
                           &amp; Mobile Business Solutions</b></td>

Stylesheet definition:
.text11WtB {font-weight: bold; font-size: 11px; color: #FFFFFF; font-family:
Verdana, Arial, sans-serif; }

Peace.....
(Reporter)

Comment 2

15 years ago
Here is a test link which uses the sample HTML and style sheet info posted
previously:

http://www.captaris.com/csstest.html

Peace.....

Comment 3

15 years ago
The culprit is these two lines:

<!-- 11px BOLD WHITE -->
.text11WtB {font-weight: bold; font-size: 11px; color: #FFFFFF; font-family:
Verdana, Arial, sans-serif; }

The HTML comment TAGS get ignored, so the parser is trying to deal with "11px
BOLD WHITE .test11WtB".  Proper CSS comments are formed /*like this*/.

IE only renders it properly because it is designed to parse CSS improperly when
coders make this mistake.

A useful tool for finding CSS errors is the W3 CSS Validator, found at
http://jigsaw.w3.org/css-validator/

Comment 4

15 years ago
Correction: should be "IE only renders it how you expect it to" instead of "IE
only renders it properly".  Sorry for the mistake.
> The HTML comment TAGS get ignored

No, they do not.  The CSS rule here is:

<!-- 11px BOLD WHITE --> .text11WtB { .. }

The selector is "<!-- 11px BOLD WHITE --> .text11WtB".  Which is not recognized
and gets dropped by the CSS parser, per the CSS spec.

IE's parser is buggy, as comment 3 points out.

Marking invalid, especially since the site is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.