Closed Bug 1647322 Opened 4 years ago Closed 4 years ago

Unmute button won't work in PiP if having touch simulation on

Categories

(DevTools :: Responsive Design Mode, defect, P3)

defect

Tracking

(firefox77 unaffected, firefox78 unaffected, firefox79 wontfix, firefox80 fixed)

RESOLVED DUPLICATE of bug 1625925
Tracking Status
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- wontfix
firefox80 --- fixed

People

(Reporter: clara.guerrero, Assigned: mtigley)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

[Affected versions]:
Nightly 79.0a1 (2020-06-22)
(notice that beta and release won't have mute button available)

[Affected platforms]:
MacOs 10.14
Win 10 pro

[Preconditions]
Have devtools.responsive.browserUI.enabled = true

Steps :

1- Launch the Firefox browser
2- Reach youtube
3- Hit Cmd+option+M in order to start Responsive Design Mode, have both "reload when touch simulation is toggled" and "reload when user agent is changed" CHECKED, and Enable Touch Simulation.
4- select any device from the list for example (if responsive option is by default pip button won't be displayed until starting video)
5- Notice that " tap to unmute" button is displayed
6- click on pip button to open pip mode
7- try to mute/unmute

Expected Results :
button should work with Touch simulation on and off

Actual Results :
button is not working the first time pip is opened, user needs to close pip and open it again and then button will work.

note: if trying these steps with touch simulation off, pip works every time

Thanks for reporting! I was also able to reproduce on Firefox 79 Nightly.

Assignee: nobody → mtigley
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P3

Hi Micah, when having touch simulation on and touching pip button, video pauses, but this won't happen with touch simulation disabled.
Please see attached video. Best,
Clara

Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.