Closed Bug 1647330 Opened 4 years ago Closed 4 years ago

Pip not working with RDM activated

Categories

(DevTools :: Responsive Design Mode, defect, P3)

defect

Tracking

(firefox77 wontfix, firefox78 wontfix, firefox79 wontfix, firefox80 fixed)

RESOLVED WORKSFORME
Tracking Status
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- fixed

People

(Reporter: clara.guerrero, Unassigned)

Details

Attachments

(1 file)

[Affected versions]:
Nightly 79.0a1 (2020-06-22)
Beta 78.0b9 (64-bit)
Release 77.0.1

[Affected platforms]:
MacOs 10.14

[Preconditions]
Have devtools.responsive.browserUI.enabled = false

Steps :

1- Launch the Firefox browser
2- Reach youtube
3- Hit Cmd+option+M in order to start Responsive Design Mode, have both "reload when touch simulation is toggled" and "reload when user agent is changed" CHECKED, and Enable Touch Simulation.
3- try opening pip by clicking button
4- disable touch simulation
5- try opening pip by clicking button once again

Expected Results :
pip should work with Touch simulation on and off

Actual Results :
user cannot open pip by clicking.

Thank you for reporting this Clara! It's certainly a bug that should be addressed. It also raises the question of whether or not RDM should be showing PIP on a simulated mobile device. I don't believe we do this on Firefox Android or iOS, so we probably shouldn't be Pip in when simulating a mobile device in RDM.

Severity: -- → S3
Priority: -- → P3

Working for me, while testing Bug 1647322 which requires PiP to reproduce. Is this problem still occurring for you?

Flags: needinfo?(clara.guerrero)

Hi!

I've just tested this in macOs 10.14 and windows 10 pro and that's correct, I cannot reproduce this anymore either.

Best,
Clara

Flags: needinfo?(clara.guerrero)

Likely fixed by the landing of Bug 1625925, but I'm not sure so I'm not going to mark this as a duplicate.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.