Browser crashs at this url

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Stephan Buchholz, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
The Browsers crashs if you type in the url "www.ivwbox.de" and pressing
return-key.

Comment 1

16 years ago
confirmed, build 2002082604;  win98

Comment 2

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

I can confirm that this happens.  The page seemed to load without a hitch, but
hitting the back button resulted in a crash.

Quality Feedback ID: TB9915106E

Comment 3

16 years ago
wfm 20020826 on linux

hitting back, browse some links, reload, etc.. works fine

Comment 4

16 years ago
Confirming crash on Win2000, 2002082608

TB9916387Q

Updated

16 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Updated

16 years ago
Keywords: stackwanted
Whiteboard: TB9916387Q

Comment 5

16 years ago
Works fine on Solaris 5.9 with cvs 20020823

Comment 6

16 years ago
wfm on Mozilla 1.1 final under Windows NT 4.0
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

I get a redirection to http://www.ivw.de/ for your URL.

Comment 7

16 years ago
Is there an setting in the preference that would restrict the browser re-direct?

Comment 8

16 years ago
Works for me on Linux,
crash on Windows NT with Mozilla 1.1 release - TB9934062H

Comment 9

16 years ago
Stephen, should I ask you for TB9916387Q?

Comment 10

16 years ago
Sound like a Window-related issues because it all point to Windows.  So the
Platform and OS setting stand correct.
Cruddy stack (sorry).

ntdll.dll + 0x4b03d (0x77fcb03d)
MSVCRT.DLL + 0x1426 (0x78001426)
MSVCRT.DLL + 0x13c3 (0x780013c3) 
Keywords: stackwanted

Comment 12

16 years ago
WFM, Moz 1.1, Win95

Comment 13

16 years ago
Incident #9915106 (comment #2)
--------------------------
Product ID  MozillaTrunk
Build ID 2002082611
URL visited http://www.ivwbox.de
User Comments Bug 164764

Stack Trace
KERNEL32.DLL + 0xa138 (0xbff7a138)
MSVCRT.DLL + 0x113d (0x7800113d)
FreeArenaList [plarena.c, line 272]
nsCOMPtr_base::assign_with_AddRef
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 70]
FrameArena::~FrameArena
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 606]
nsCOMPtr_base::assign_with_AddRef
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 70]
nsTextInputListener::Release
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsTextControlFrame.cpp, line 252]
DocumentViewerImpl::Destroy
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 1744] 
Whiteboard: TB9916387Q

Comment 14

16 years ago
wfm on mozilla 1.1b+ (2002082704) on win98se

Comment 15

16 years ago
OS: Win XP Pro
Build: 20020826

Crash ID: TB9941593X
Navigated to http://www.ivwbox.de and it crashed within a minute

Comment 16

16 years ago
The stack in comment #15: 

Product ID  MozillaTrunk
Build ID 2002082611
User Comments I navigated to this page (got redirected from another site) and
the page loaded okay. But the browser crashed within a minute of the page
loading, after I used prev and next.

Stack Trace
ntdll.dll + 0x27b88 (0x77f67b88)
ntdll.dll + 0x2b763 (0x77f6b763)
ntdll.dll + 0x1612e (0x77f5612e)
ntdll.dll + 0x2b831 (0x77f6b831)
ntdll.dll + 0x2641b (0x77f6641b)
msvcrt.dll + 0x1b9b1 (0x77c0b9b1)
nsImageWin::CleanUpDIB
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp, line 1159]
nsImageWin::Release [c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp,
line 110]
nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65]
gfxImageFrame::`scalar deleting destructor'
gfxImageFrame::Release [c:/builds/seamonkey/mozilla/gfx2/src/gfxImageFrame.cpp,
line 38]
nsSupportsArray::Clear
[c:/builds/seamonkey/mozilla/xpcom/ds/nsSupportsArray.cpp, line 560]
imgContainer::~imgContainer
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgContainer.cpp, line 62]
imgContainer::`scalar deleting destructor'
imgContainer::Release
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgContainer.cpp, line 36]
nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65]
imgRequest::~imgRequest
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 80]
imgRequest::`scalar deleting destructor'
imgRequest::Release
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 59]
EventHandler [c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp,
line 1050]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 530]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1078]
USER32.dll + 0x199e2 (0x77d499e2)
USER32.dll + 0x2be43 (0x77d5be43)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1534]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1881]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1899]
WinMainCRTStartup()
kernel32.dll + 0x372db (0x77e872db)

Comment 17

16 years ago
seems like the page was chnaged maybe???
you are redirected to www.ivw.de now
can not confirm on Win98SE and moz1.1 build 2002082704 anyway

Comment 18

16 years ago
Works for me.  Hit page, clicked on links, back button, etc... no crashes on my end.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

JOhn

Comment 19

16 years ago
Unable to reproduce crash, marking as WFM due to comments 17 and 18. If someone
still crashes at this URL please reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.