ASSERTION: Failed to write xpti manifest!: 'Error'

RESOLVED INVALID

Status

()

Core
XPCOM
--
critical
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Stef Bon, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I've downloaded the source of mozilla 1.1b, configured with the flags : 
 
--with-x --with-system-zlib --with-system-jpeg --with-system-png 
--with-system-mng 
 
compiled and installed the software, 
 
Then after a lot of messages like the first lines, it crashes. So, I can't 
start the program, it crashes immediatly.  
 
The output of the program is : 
(only the last part) 
 
*** Registering nsAbModule components (all right -- a generic module!) 
*** Registering nsImportServiceModule components (all right -- a generic 
module!) 
*** Registering nsTextImportModule components (all right -- a generic module!) 
*** Registering nsComm4xMailImportModule components (all right -- a generic 
module!) 
*** Registering nsAbSyncModule components (all right -- a generic module!) 
*** Registering nsMsgMdnModule components (all right -- a generic module!) 
nsNativeComponentLoader: autoregistering succeeded 
###!!! ASSERTION: Failed to write xpti manifest!: 'Error', file 
xptiInterfaceInfoManager.cpp, line 1937 
Break: at file xptiInterfaceInfoManager.cpp, line 1937 
 
Program /usr/local/lib/mozilla-1.1b/mozilla-bin (pid = 31945) received 
Segmentation fault signal. 
Stack: 
UNKNOWN 0x403524f3 
UNKNOWN 0x40684898 
JS_InternString+0x00000022 [/usr/local/lib/mozilla-1.1b/libmozjs.so 
+0x00017CC2] 
XPCNativeInterface::GetNewOrUsed(XPCCallContext&, nsID const*)+0x00000184 
[/usr/local/lib/mozilla-1.1b/components/libxpconnect.so +0x00086B9A] 
XPCConvert::NativeInterface2JSObject(XPCCallContext&, 
nsIXPConnectJSObjectHolder**, nsISupports*, nsID const*, JSObject*, 
unsigned*)+0x00000127 [/usr/local/lib/mozilla-1.1b/components/libxpconnect.so 
+0x0005CB5B] 
XPCConvert::NativeData2JS(XPCCallContext&, long*, void const*, nsXPTType 
const&, nsID const*, JSObject*, unsigned*)+0x00000944 
[/usr/local/lib/mozilla-1.1b/components/libxpconnect.so +0x0005B8F8] 
nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, 
nsXPTMethodInfo const*, nsXPTCMiniVariant*)+0x00000AD3 
[/usr/local/lib/mozilla-1.1b/components/libxpconnect.so +0x0007A395] 
nsXPCWrappedJS::CallMethod(unsigned short, nsXPTMethodInfo const*, 
nsXPTCMiniVariant*)+0x00000065 
[/usr/local/lib/mozilla-1.1b/components/libxpconnect.so +0x000740EB] 
UNKNOWN 0x4028cccb 
UNKNOWN 0x4028cd36 
mozJSComponentLoader::AutoRegisterComponent(int, nsIFile*, int*)+0x0000013F 
[/usr/local/lib/mozilla-1.1b/components/libjsloader.so +0x00011357] 
mozJSComponentLoader::RegisterComponentsInDir(int, nsIFile*)+0x000001D5 
[/usr/local/lib/mozilla-1.1b/components/libjsloader.so +0x00010FFF] 
mozJSComponentLoader::AutoRegisterComponents(int, nsIFile*)+0x0000002B 
[/usr/local/lib/mozilla-1.1b/components/libjsloader.so +0x00010E23] 
nsComponentManagerImpl::AutoRegisterImpl(int, nsIFile*, int)+0x00000770 
[/usr/local/lib/mozilla-1.1b/libxpcom.so +0x001091F8] 
nsComponentManagerImpl::AutoRegister(nsIFile*)+0x0000003A 
[/usr/local/lib/mozilla-1.1b/libxpcom.so +0x001097E2] 
NS_InitXPCOM2+0x0000082D [/usr/local/lib/mozilla-1.1b/libxpcom.so +0x00097379] 
main+0x00000170 [/usr/local/lib/mozilla-1.1b/mozilla-bin +0x00015F66] 
__libc_start_main+0x0000008E [/lib/libc.so.6 +0x0001C316] 
Sleeping for 5 minutes. 
Type 'gdb /usr/local/lib/mozilla-1.1b/mozilla-bin 31945' to attatch your 
debugger to this thread. 
 
I start up with  
 
mozilla &  
 
from the command line, as an arbitrary user. This makes no difference, I also 
tried as root. 
 
 
Stef Bon
(Reporter)

Updated

15 years ago
Severity: minor → blocker
(Reporter)

Updated

15 years ago
Priority: -- → P1
*** Bug 169120 has been marked as a duplicate of this bug. ***
I forgot to ask : Have you tried a binary from mozilla.org ?

-> XpCom (or build config ?)

next question: Do you sure that you want a debug build ?

(use "--disable-debug" if you only want a  optimized "normal" build and if you want 
to visit https pages you need also "--enable-crypto")

Assignee: asa → dougt
Severity: blocker → critical
Component: Browser-General → XPCOM
Priority: P1 → --
QA Contact: asa → scc
(Reporter)

Comment 3

15 years ago
reaction on comment #2 :    
I also tried to use mozilla via the installer, that works ok.   
   
I've gcc version 3.1.1, glibc 2.2.5.   
Platform PC, OS Linux 2.4.19.   
   
What do you mean with :  
  
XpCom (or build config ?) 
 
Stef  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

15 years ago
As far I can see this bug isn't solved. So it is not resolved yet. 
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 5

15 years ago
I've downloaded a new source, from the latest builds, 23-09, version 1.2b and 
build it again, with the flags 
 
./configure --prefix=/usr/local/mozilla-try --enable-crypto --disable-debug 
make 
make install 
 
Installed as root. 
 
Now I've got an error in line 72    $prog ${1+"$@"} Segmentation fault 
 
This can mean anything. There is no information about what happened. 
So I reconfigured : 
 
rm /usr/local/mozilla-try 
make distclean 
./configure --prefix=/usr/local/mozilla-try --enable-crypto 
make 
make install 
 
Now starting mozilla, 
a lot of messages which are the same as shown in the first place: 
 
mozilla 
 
No Persistent Registry Found. 
Type Manifest File: 
/usr/local/mozilla-try/lib/mozilla-1.2b/components/xpti.dat 
nsNativeComponentLoader: autoregistering begins. 
 
--snip 
 
*** Registering nsImportServiceModule components (all right -- a generic 
module!) 
*** Registering nsTextImportModule components (all right -- a generic module!) 
*** Registering nsComm4xMailImportModule components (all right -- a generic 
module!) 
*** Registering nsAbSyncModule components (all right -- a generic module!) 
*** Registering nsMsgMdnModule components (all right -- a generic module!) 
*** Registering nsMsgSMIMEModule components (all right -- a generic module!) 
nsNativeComponentLoader: autoregistering succeeded 
 
Program /usr/local/mozilla-try/lib/mozilla-1.2b/mozilla-bin (pid = 9596) 
received Segmentation fault signal. 
Stack: 
UNKNOWN 0x40323f75 
UNKNOWN 0x42029098 
XPCNativeInterface::GetNewOrUsed(XPCCallContext&, nsID const*)+0x00000184 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libxpconnect.so 
+0x000879D2] 
XPCConvert::NativeInterface2JSObject(XPCCallContext&, 
nsIXPConnectJSObjectHolder**, nsISupports*, nsID const*, JSObject*, 
unsigned*)+0x00000127 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libxpconnect.so 
+0x0005DAC7] 
XPCConvert::NativeData2JS(XPCCallContext&, long*, void const*, nsXPTType 
const&, nsID const*, JSObject*, unsigned*)+0x00000944 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libxpconnect.so 
+0x0005C864] 
nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, 
nsXPTMethodInfo const*, nsXPTCMiniVariant*)+0x00000AD3 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libxpconnect.so 
+0x0007B1BB] 
nsXPCWrappedJS::CallMethod(unsigned short, nsXPTMethodInfo const*, 
nsXPTCMiniVariant*)+0x00000065 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libxpconnect.so 
+0x00074DBD] 
UNKNOWN 0x40265bdb 
UNKNOWN 0x40265c46 
mozJSComponentLoader::AutoRegisterComponent(int, nsIFile*, int*)+0x0000013F 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libjsloader.so 
+0x00011B3B] 
mozJSComponentLoader::RegisterComponentsInDir(int, nsIFile*)+0x000001D5 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libjsloader.so 
+0x000117E3] 
mozJSComponentLoader::AutoRegisterComponents(int, nsIFile*)+0x0000002B 
[/usr/local/mozilla-try/lib/mozilla-1.2b/components/libjsloader.so 
+0x00011607] 
nsComponentManagerImpl::AutoRegisterImpl(int, nsIFile*, int)+0x0000074B 
[/usr/local/mozilla-try/lib/mozilla-1.2b/libxpcom.so +0x0010A6EF] 
nsComponentManagerImpl::AutoRegister(nsIFile*)+0x0000003A 
[/usr/local/mozilla-try/lib/mozilla-1.2b/libxpcom.so +0x0010ACDA] 
NS_InitXPCOM2+0x0000083B [/usr/local/mozilla-try/lib/mozilla-1.2b/libxpcom.so 
+0x00097997] 
main+0x00000170 [/usr/local/mozilla-try/lib/mozilla-1.2b/mozilla-bin 
+0x000181DE] 
__libc_start_main+0x00000095 
[/usr/local/mozilla-try/lib/mozilla-1.2b/mozilla-bin +0x00017499] 
Sleeping for 5 minutes. 
Type 'gdb /usr/local/mozilla-try/lib/mozilla-1.2b/mozilla-bin 9596' to attatch 
your debugger to this thread. 
 
So I did 
 
gdb /usr/local/mozilla-try/lib/mozilla-1.2b/mozilla-bin 9596 
 
Now I have never worked with this debugger, how can I get more information 
about what's going on?? 
 
Stef 
(Reporter)

Comment 6

15 years ago
Hello, 
 
I do not get the idea that this bug is being noticed or taken care off. I 
would really get your attention to it. 
So I reassign it to you. 
 
Stef Bon 

Comment 7

15 years ago
*** Bug 163488 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Stef, the first time mozilla is run after installation, it registers a bunch of
components and writes out a file containing the results to the mozilla
directory. The assertion "Failed to write xpti manifest!" implies that it wasn't
able to create that file. A likely reason is that the user who launched mozilla
didn't have permission to create files within the mozilla installation directory.

If you want to install mozilla as root and then run it as a regular user, you
have to run some things as root to explicitly create this file. After that,
normal users should be able to run mozilla without trouble. The steps are
described in <http://www.mozilla.org/releases/mozilla1.2.1/#install>.

Please try the procedure outlined and report your results by updating this bug
report.

Comment 9

15 years ago
Stef, are you still experiencing this problem? Could you respond to comment 8,
please?

Comment 10

15 years ago
No response from the reporter. Resolving INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.