Closed Bug 1647699 Opened 3 months ago Closed 3 months ago

[Acer builds] The default search engine changes on some of the locale builds

Categories

(Firefox :: Distributions, defect, P1)

78 Branch
All
Windows
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 79
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- fixed
firefox77 --- unaffected
firefox78 + verified
firefox79 --- verified

People

(Reporter: oana.botisan, Assigned: standard8)

Details

Attachments

(2 files)

Attached file distribution.7z

Suggested severity

  • S2

Affected versions

  • Firefox 78.0

Affected platforms

  • Windows 10 x64
  • Windows 7 x64

Prerequisites

  • Install the old version of firefox (< 72.0.2), but do not start it, change update channel to release-localtest with the locale "pl".
  • Unpack the attached file and place them inside the Firefox install folder (ex: Firefox/distribution)
  • Start CMD as admin and input the following comands to remove all profile data:
    rd /s /q %userprofile%\AppData\Roaming\Mozilla
    rd /s /q %userprofile%\AppData\Local\Mozilla
    rd /s /q %userprofile%\AppData\LocalLow\Mozilla

Steps to reproduce

  1. Start Firefox with the default profile.
  2. Update Firefox to the latest version.
  3. Perform a search from the URL bar.

Expected result

  • The search is performed with Bing.

Actual result

  • The search is performed with Google.

Regression range

  • I can't a regression, because I can't control to which build the update is last performed to.

Additional notes

  • This issue is reproducing on other locales, too (e.g. ru).
  • This changes happen only after the build is updated from 72.0.2 to the latest build.

Sounds like the search config from the distribution is not being used after the update?

Flags: needinfo?(standard8)
Flags: needinfo?(mozilla)

According to the old partner distribution repos, acer is only distributed for en-US builds. Bing is not shipped to all locales, including pl and ru, so if you change locale to be one of those, then Bing won't show up.

Previously we probably would have installed Bing regardless, because of the distribution configuration.

Not sure if this something we missed or if it is generally OK. I'll let Mike comment in that respect.

Flags: needinfo?(standard8)

Any engine that is on the common directory needs to apply for all locales. So in this case, Bing with the new codes should have been used everywhere with Bing as the default. Acer uses language packages so the languages it's built in is misleading

Flags: needinfo?(mozilla)

I'll verify the locales that Acer is shipped in though.

I've verified these machines are worldwide. So we need to add Bing when it isn't there.

Do we need to worry about any of the other partner repacks?

Flags: needinfo?(mozilla)

I think Acer is the only one with this issue because of the absence of Bing in some locales. Most other partner repacks add the engine they need.

Flags: needinfo?(mozilla)

I'm working on updating remote settings for the changes required. There's making Acer have Bing everywhere, as well as ensuring the Google is default for sweetlabs in all places.

I'm currently running our tests at the moment to check I haven't regressed the defaults.

With the modern configuration, there's a couple of steps to this:

  • Update remote settings and post it so that QA can do a quick verification (we'll use production's main-preview this time around).
  • Get final approval on production.
  • We can then either wait for a day or so for remote settings to update the repositories automatically... or
  • I can produce a patch to the repositories that updates the remote settings part (I guess we'll do this because of timescales).

I'll also add a couple of spot-check tests for Acer to make sure Bing is enabled in locations we don't normally have it.

I've attached a test that we can land later once the new configuration is approved.

The new configuration is on the remote settings production server on main-preview. The configuration passes the in-tree tests for the main search engines and the distribution tests. Once QA can check it, we'll get it signed off.

Oana, you should be able to test with a of 78.0, and setting remote settings to read main-preview from production. Once you've change the main-preview, cleared the local data and polled changes, you should be able to wait 5 minutes (with whole system idle), or restart, and Bing should then show up as the default again.

Cristian, could your team do a few spot-checks on main-preview? I've only change parts relating to the distribution, but it would be good to just to do a few quick ones to ensure there isn't something non-obvious broken.

Assignee: mozilla → standard8
Flags: needinfo?(oana.botisan)
Flags: needinfo?(cristian.comorasu)
Flags: needinfo?(oana.botisan)

After we connected to the main-preview server we tested acer-003 and acer-002 on Windows 10 x64 and macOS 10.13.6(with dump true and dump false)
We also upgrades from 58, 60 (via 72.0-watershed) with the en-US and PL locales.
The were no issues encountered.

Flags: needinfo?(cristian.comorasu)

I've asked mconnor to approve the changes on remote settings. I'll update when this is done.

Attachment #9158655 - Attachment description: Bug 1647699 - Extend test_distribution to cover Acer distribution fixes. → Bug 1647699 - Extend test_distribution to cover Acer distribution fixes. r?mkaply
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa860755bfcd
Extend test_distribution to cover Acer distribution fixes. r=mkaply

The changes are now live on production. I'm requesting uplift of the patch to ensure we get the configuration updated for the next builds and to get the tests added.

Comment on attachment 9158655 [details]
Bug 1647699 - Extend test_distribution to cover Acer distribution fixes. r?mkaply

Beta/Release Uplift Approval Request

  • User impact if declined: Users of the Acer related distributions may not have the correct default engine (See also dependant bug).

The configuration change has just been approved on remote settings. This patch is applying the configuration change from remote settings to the repositories so that the updated configuration is included within Firefox as soon as a user installs it.

Normally this happens via automation, however since we're close to release, I'm offering this so we can ensure it is there on time.

The patch also includes test-only changes to cover the changes in the configuration.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: As per comment 0.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small change to the distribution part of the configuration. We have automated tests for the main search engines, and for distributions. This is just landing the configuration that has already been pushed out via remote settings.
  • String changes made/needed: none
Attachment #9158655 - Flags: approval-mozilla-release?
Attachment #9158655 - Flags: approval-mozilla-esr78?
Flags: qe-verify+
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
Severity: -- → S3
Iteration: --- → 78.2 - May 18 - May 31
Points: --- → 2
Priority: -- → P1

I verified the fix on latest Nightly (2020-06-25) on Windows 10 x64, Windows 8.1 x32 and Windows 7 x32. The issue is not reproducing anymore. The search engine is Bing and the code in the search is pc=MOZD.

Comment on attachment 9158655 [details]
Bug 1647699 - Extend test_distribution to cover Acer distribution fixes. r?mkaply

thanks Mark. approved for 78 rc2.

Attachment #9158655 - Flags: approval-mozilla-release?
Attachment #9158655 - Flags: approval-mozilla-release+
Attachment #9158655 - Flags: approval-mozilla-esr78?
Attachment #9158655 - Flags: approval-mozilla-esr78+
QA Whiteboard: [qa-triaged]

We verified the fix on Firefox 78.0 rc2 on Windows 10 x64, Windows 8.1 x32 and Windows 7 x64. The issue is not reproducing anymore. The search engine is Bing and the code in the search is pc=MOZD.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.