Japanese message body (iso-2022-jp and Shift-Jis) doesn't display correctly in case of Forward

VERIFIED FIXED

Status

MailNews Core
Internationalization
--
major
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Roger Meunier, Assigned: nhottanscp)

Tracking

({intl, regression})

Trunk
x86
Windows 2000
intl, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using Mozilla 1.1.  Original mail in Japanese (ISO-2022-JP) codeset.
Displays OK in viewer.  Displays OK in composition window when "Reply"ing, but
not when "Forward"ing.
To be precise, ISO-2022-JP displays properly in header, but not in body of
quoted message.

Comment 1

16 years ago
Roger, please see bug # # 162593, if deleting component registry file cures your
problem, mark this as a dup. Thanks.
(Reporter)

Comment 2

16 years ago
Deleting compreg.dat did not resolve this problem.  Some mail contents display
properly, but others are either partly munged or the entire text is treated as
7-bit characters.

Mail content as simple as:

これは、漢字のテストです。

Is seen in the Compose window (when forwarding) as:

$B$3$l$O!"4A;z$N%F%9%H$G$9!#(B

Is there something I can supply that can help you reproduce the problem?

Comment 3

16 years ago
Could you please attach a problematic message before forwarding? Thanks.
(Reporter)

Comment 4

16 years ago
Created attachment 101216 [details]
mail folder-file containing sample data

place this file in your Mozilla mail directory.
start up Mozilla Mail. select the folder. select the message.
click Forward.	The message body text will not display properly, though the
Japanese in the Header displays correctly.

Comment 5

16 years ago
yes, i can confirm that in case of Forwarding the body in japanese encodings:
iso-2022-jp and Shift-JIS don't work, EUC-Jp somehow doesn't seem to be
affected. Chinese encodings work also. I tested with Roger's sample mail and
with a test folder BodyMime (all mail in this folder display body correctly
except the two mentionned above)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: intl

Updated

16 years ago
Keywords: regression
Summary: forwarded mail won't display properly in composition window → Japanese message body (iso-2022-jp and Shift-Jis) doesn't display correctly in case of Forward

Comment 6

16 years ago
it looks like the JIS that is not working is with Hankaku Kana allowed.

Comment 7

16 years ago
broken on the trunk, branch is OK, nominating
Keywords: nsbeta1

Comment 8

15 years ago
I think we should fix this asap. P2 bug. Estimate 4-7 days of debugging
Blocks: 157673

Comment 9

15 years ago
i18n triage team: nsbeta1+/adt1
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]
(Assignee)

Comment 10

15 years ago
I do not see the problem using my local trunk build (pulled this morning).
I tried forward inline for plain and html using the attached message.
Marina, could you try latested trunk?
(Assignee)

Comment 11

15 years ago
I think this was probably fixed by bug 120728.
(Assignee)

Comment 12

15 years ago
so mark as fixed
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
verifying as fixed using 20030602 build
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.