mozilla lies about the existence of profiles because the profile List is not live

RESOLVED WONTFIX

Status

()

Toolkit
Startup and Profile System
RESOLVED WONTFIX
16 years ago
5 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
run mozilla in such a way to trigger the profile manager (i'm running mozilla
nightly and netscape7p1 on my console and victimizing mozilla1.1 in a terminal
session).

in profilemanager, create a profile 'victim'
quit mozilla
in filemanager, rename the 'victim' folder (or trash it)
run mozilla
in filemanager, restore the 'victim' folder
select 'victim'
click start mozilla

expect: mozilla to start
actual results: Mozilla cannot use the profile "victim" because the directory
containing the profile cannot be found.

the fact is that victim could be found if mozilla looked when asked, but mozilla
didn't do that.

the list of profiles, their paths, and existence are read before profilemanager
shows its ui and not checked again.

Comment 1

16 years ago
It will be helpful if the bugzilla helper is being used.  It make the bug report
less confusing.

Comment 2

16 years ago
Moving comments Reporter send to me by email back into bugzilla.  My email is 
not a tool for bugzilla comments.

--clip--
it would not. i'm inherently confusing. it doesn't matter if i use the 
helper, my bugs are still confusing. just leave my bugs alone. i didn't 
file this as unconfirmed, i filed it in the component where it belongs and 
with enough details. if you're interested in fixing the bug (which is 
highly unlikely), then contact me asking for information, i can point you 
to the specific lines of code where the problem lives.
--clip--
Product: Browser → Seamonkey

Comment 3

13 years ago
A slightly less confusing bug report:

Summary: Mozilla only checks profile directory-existence at startup.

Steps to reproduce:
1. Create another Mozilla profile called REMOVABLE on a removable drive - such
as a REV drive/PGP Disk/Network Drive/USB key.
2. Close Mozilla.
3. Unmount the removable drive.
4. Start Mozilla, using the DEFAULT profile.
5. Remount the removable drive (using the same mount-point/drive letter).
6. Try to switch to the new profile on the removable drive.

Actual Results:
Mozilla displays the following error:
"Mozilla cannot use the profile REMOVABLE because the directory containing the
profile cannot be found."

Expected Result:
Mozilla switches to the REMOVABLE profile.
Assignee: bugs → nobody
QA Contact: ktrina → profile-manager

Updated

7 years ago
Component: Startup & Profiles → Startup and Profile System
Product: SeaMonkey → Toolkit
QA Contact: profile-manager → startup

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.