Closed Bug 1648089 Opened 4 years ago Closed 4 years ago

Back browser button updates the URL accordingly while in RDM, but page itself won't update.

Categories

(DevTools :: Responsive Design Mode, defect)

defect

Tracking

(firefox77 disabled, firefox78 disabled, firefox79 wontfix)

RESOLVED INVALID
Tracking Status
firefox77 --- disabled
firefox78 --- disabled
firefox79 --- wontfix

People

(Reporter: clara.guerrero, Assigned: mtigley)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Attached video back.mov

[Affected versions]:
Nightly 79.0a1 (2020-06-23)

Windows 10
MacOs 10.14

[Preconditions]
Have devtools.responsive.browserUI.enabled = true

Steps :

1- Launch the Firefox browser and reach https://css-tricks.com/examples/State/
2- Hit Ctrl+Shift+M in order to start Responsive Design Mode.
3- Click on any icon
4- Touch back button
5- URL updates and user goes back one page.
6- Change device
7- Click on any icon
8- Change device.
9- Resolution changed accordingly, now just one icon is displayed
10- Touch back button

Expected Results :
Back browser button should update the URL accordingly while in RDM, and user should go back one page as well.

Actual Results :
URL updates but page is stuck displaying same content.

Thanks for reporting! I was able to reproduce consistently in Firefox Nightly 79 with the following steps:

  1. Go to https://css-tricks.com/examples/State/
  2. Open RDM and ensure that the setting "Reload when user agent is changed" is toggled on.
  3. Select iPad device from the dropdown menu.
  4. Click on any of the portrait links. This will take the user to a subroute.
  5. Resize the RDM viewport.
  6. Try navigating back to go back to the original URL.

Expected Results
The user should see the page display all portraits from the original route.

Actual results
The portrait on the subroute is still displayed.

Assignee: nobody → mtigley
Status: NEW → ASSIGNED

I also tried reproducing this without RDM activated and can also see the same issue. Here are the following steps:

  1. Go to https://css-tricks.com/examples/State/
  2. Click on any of the portrait links. This will take the user to a subroute.
  3. Refresh the page.
  4. Try navigating back with the "Back" button.

Expected Results
The user should see the page display all portraits from the original route.

Actual results
The portrait on the subroute is still displayed.

Attached video navigation_issue.mov

Another thing I'm noticing is that this is also reproducible on Google Chrome 83. So I don't the issue is Firefox-specific.

Clara, can you confirm that the STR in Comment 2 is happening for you in both Firefox and Google Chrome?

Flags: needinfo?(cguerrero)

Hi Micah,
Yes I can also reproduce both ff and Chrome! Let me know if you need help with anything else.
Best,
Clara

Flags: needinfo?(cguerrero)

Great! Thanks for confirming Clara. This issue is specific to https://css-tricks.com/examples/State/ and I'm also able to confirm that using Back/Forward nav buttons while RDM is activated is working in Firefox 79 Nightly on any other website.

I believe we can close this issue. If it turns out that we are able to find a general occurrence where the Back/Forward buttons are not working in RDM (for Firefox 79 Nightly), then we can re-open.

Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: