cannot use java plugin with certain settings of general.useragent.override

VERIFIED DUPLICATE of bug 83376

Status

defect
VERIFIED DUPLICATE of bug 83376
17 years ago
9 years ago

People

(Reporter: remco, Assigned: ping.liao)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When you set general.useragent.override to eg:
user_pref("general.useragent.override", 
"Netscape/4.7 (X11; U; Linux i686; en-US; rv 0.9.2) Gecko/20010726Netscape4/4.7");
the java plugin complains:
 INTERNAL ERROR on Browser End: Expected a version > 5! Version = 0

Comment 1

17 years ago
reassign to OJI
Assignee: beppe → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 2

17 years ago
Re-assign to Ping.
Assignee: joe.chou → ping.liao

Comment 3

17 years ago
I have the same problem w/ Linux(RH7.3/KDE) on an IBM 390x Thinkpad. I installed
the Java plugin from an XPI object(directed from: news.bbc.co.uk). When I
restarted Mozilla it complained: "INTERNAL ERROR on Browser End: Expected a
version > 5! Version = 4" and died. When I changed my agent override in prefs.js
to a version 5 or greater my browser started with out error. Hope this helps.
Contact me with any questions.

Comment 4

17 years ago
A simmilar error occured on the windows platform.   I installed the JRE using
the XPI and in user.js i had the following setting:
user_pref("general.useragent.override","Mozilla/4.98 [en] (Windows NT 5.0; U)");
Upon starting mozilla I recieve the following error messages from the JAVA plugin:
"Unable to obtain proxy configuration from Netscape Navigator 4.5 or later -
fallback."
then after clicking ok
"Unable to obtain proxy configuraion from Netscape Navigator 4.0.x - fallback.

Then after clciking OK mozilla starts ok, but java applets do not run.

I have to set the useragent to a version 4 of netscape becasue a subscription
service we pay for at work checks the browser version string and insists that
any netscape above version 4 does not have javascript supprort. I invented this
version number to combat that, and still allow me to distingush hits to our
server by our copy of mozilla.  

Updated

17 years ago
QA Contact: pmac → petersen

Comment 5

17 years ago
Sounds like a dupe of bug 83376

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.