Closed Bug 1648385 Opened 7 months ago Closed 7 months ago

Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used

Categories

(Firefox :: Address Bar, defect, P2)

77 Branch
defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 80
Iteration:
79.2 - June 15 - June 28
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- fixed
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed
firefox80 --- fixed

People

(Reporter: dust.harvesting, Assigned: harry)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

I have the Use the address bar for search and navigation option enabled. With Show search suggestions in address bar results disabled I've typed the search term in the address bar with the preceding question mark.

Actual results:

I don't see the search suggestions in address bar results.

Expected results:

I expected to see the suggestions in address bar results. This worked previously, perhaps it stopped since 77. I've also tested it in 79.0a1 (2020-06-24) and got the same result.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar

Suggestions should be visible when a token alias or question mark are typed (when the urlbar is in search restriction mode), This likely means we don't have a test for this case.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Regressed by: 1623637
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 79.2 - June 15 - June 28
Points: --- → 2

Set release status flags based on info from the regressing bug 1623637

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/99e4b7a631a6
Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used. r=adw
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80

The patch landed in nightly and beta is affected.
:harry, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(htwyford)

Comment on attachment 9159417 [details]
Bug 1648385 - Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used. r?adw

Beta/Release Uplift Approval Request

  • User impact if declined: Regression where some users won't be able to get search suggestions in the address bar.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small frontend patch with multiple unit tests.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9159417 - Flags: approval-mozilla-beta?

Comment on attachment 9159417 [details]
Bug 1648385 - Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used. r?adw

Approved for 79.0b3. Thanks for including tests.

Attachment #9159417 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
See Also: → 1513459

Is this something we should consider fixing for ESR78 also or can this ride with release?

Flags: needinfo?(htwyford)

Comment on attachment 9159417 [details]
Bug 1648385 - Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used. r?adw

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This bug deals with accessing search suggestions in environments where suggestions are disabled in the address bar. It's my understanding that this is more likely in corporate environments, maybe due to group policy.

Moreover, this is a low-risk fix that might increase the volume of search suggestions, which is a positive.

  • User impact if declined: Users who have search suggestions disabled in most cases in the address bar would have no way of accessing search suggestions even when trying to do so explicitly.
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch affects just one provider component of the address bar. The address bar is pretty modular, so the chance of something going wrong elsewhere in the address bar is low/none. The change does not affect user data and is backed with several tests. This has baked on Nightly+Beta for almost two weeks and there's been no reported regressions.
  • String or UUID changes made by this patch:
Flags: needinfo?(htwyford)
Attachment #9159417 - Flags: approval-mozilla-esr78?

Comment on attachment 9159417 [details]
Bug 1648385 - Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used. r?adw

More likely to bite users in enterprise environments. Approved for 78.1esr.

Attachment #9159417 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
Duplicate of this bug: 1655270
See Also: → 1524190

Resummarizing to better reflect the patch that landed.

Summary: Search suggestions are missing in the address bar when searching with the "?" operator → Allow search suggestions in the Urlbar when they are disabled by a pref but a restriction token or token alias is used
You need to log in before you can comment on or make changes to this bug.