Closed Bug 1648405 Opened 1 year ago Closed 1 year ago

Use crossbeam_channel instead of std::mpsc in WebRender

Categories

(Core :: Graphics: WebRender, task, P3)

task

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: nical, Assigned: nical)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 3 obsolete files)

The main motivation is to have access to crossbeam's select feature, in the hope that we can remove some hacks we do with some even loops that pull from multiple channels. As a bonus crossbeam is reportedly much faster than std::mpsc.

Depends on D81040

Depends on D81041

This introduces a slight behavior change in that the backend messages will go directly to the scene builder thread without going through the low-priority scene builder. In most cases this should not be an issue because it only contains debugging related messages originating from user inputs so respective ordering with specific transactions is already not possible to enforce/observe.

This introduces a slight behavior change in that the backend messages will go directly to the scene builder thread without going through the low-priority scene builder. In most cases this should not be an issue because it only contains debugging related messages originating from user inputs so respective ordering with specific transactions is already not possible to enforce/observe.

Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c73ffc91ade2
Use crossbeam channels instead of std::mpsc ones in webrender. r=gw
https://hg.mozilla.org/integration/autoland/rev/50a2b61977d5
Vendor crossbeam dependency. r=gw
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---

== Change summary for alert #26628 (as of Fri, 31 Jul 2020 02:32:27 GMT) ==

Improvements:

5% tscrollx linux64-shippable-qr opt e10s stylo 1.64 -> 1.56
4% tscrollx linux64-shippable-qr opt e10s stylo 1.63 -> 1.57

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=26628

Attachment #9165861 - Attachment is obsolete: true
Attachment #9159292 - Attachment is obsolete: true
Attachment #9159264 - Attachment is obsolete: true
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Keywords: leave-open
Resolution: --- → FIXED
Regressions: 1667696
You need to log in before you can comment on or make changes to this bug.