when downloading, a ".jpg " extension is added to filename

RESOLVED INVALID

Status

Core Graveyard
File Handling
RESOLVED INVALID
15 years ago
a year ago

People

(Reporter: Chris Lowell, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

I don't remember where the problem started, I may have selected the browser as
default to look at jpgs, but for the past few weeks when I download something
with the browser, everything has had a ".jpg" added to the end of the filename.
Example - "winzip.zip" would download as "winzip.zip.jpg". I had the problem
with version 1.0, I updated to 1.1 and the problem stayed.I also uninstalled the
program and relaoded 1.1 and it is still doing the same thing. Don't know if
there's any other setting that can be adjusted.

Reproducible: Always

Steps to Reproduce:
1. Click link to download any file type
2. Grey box appears saying you have chosen to download a file of type "JPEG Image"
3. Click Save file to disk Radio button
4. Clicked after .jpg and backspaced last 4 characters and saved
Actual Results:  
File saved as normal

Expected Results:  
Should not Have detected it as a JPEG
Check you helper app preferences.  I bet you have .jpg associated with the
application/octet-stream MIME type.
QA Contact: sairuh → petersen
(Reporter)

Comment 2

15 years ago
Caused by user error. MIME type was set for binary downloads, set as .jpg;
removed that listing and the problem went away...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.