Open link in a new window or tab using command+enter in browser view

RESOLVED DUPLICATE of bug 358379

Status

--
enhancement
RESOLVED DUPLICATE of bug 358379
17 years ago
11 years ago

People

(Reporter: dereks, Assigned: bugzilla-graveyard)

Tracking

unspecified
Camino2.0
PowerPC
macOS

Details

(Reporter)

Description

17 years ago
I love the feature (most browsers have it) if you select a link with cmd-f then
hit return the link is "clicked." Would it be possible to make cmd-return the
same as cmd-click (create a new tab)

Steps:
1) Goto http://www.mozilla.org
2) "Find in Page" (cmd-f)
3) Search for "Testing"
4) esc or cmd-w to close the "Find in Page" window
5) Hit cmd-return  ----> New tab
Target Milestone: --- → Chimera1.1

Comment 1

17 years ago
Confirmed using FizzillaCFM/1.1-final on 10.1.5. Selecting a link simply by
using the tab key and pressing return loads the link, but pressing
command+return results in a beep.

It works using Mozilla 1.1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [RFE] Have cmd-return act like a cmd-click → [RFE] Implement command+return link opening in a new window or tab
Summary: [RFE] Implement command+return link opening in a new window or tab → Implement command+return link opening in a new window or tab

Comment 2

16 years ago
Would be nice if command-return opened a new window/tab when typed in the URL
bar, too.  Currently it just beeps.

This would be useful if I loaded a page, then edit the URL and want to go to it
while keeping the current one in a window.

Comment 3

16 years ago
See Bug 155863, for consistency
Cmd-Return : open selected link in a New Window
Opt-Return : open selected link in a New Tab

I did not check AAHIG, but doing the same also with the Enter key would be good too.

Comment 4

15 years ago
count me in on this, i frequently type urls into the url bar only to need to
open a new tab and type it again. seems like all other browsers do this

Comment 5

15 years ago
*** Bug 247238 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 247238 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
Changed summary as it's not reflecting more recent comments.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Implement command+return link opening in a new window or tab → Open link in a new window or tab using command+enter in browser view

Comment 8

14 years ago
I'm using 2005071808 (v0.9a2)

I notice that though I've selected that command-clicking a link should open it
in a new tab in my preferences, it does not.

Any link I command-click opens a new window and an empty tab.  Last link I tried
that prompted me to write you is while browsing in the Apple Store.  All the
links seem to do the same thing.  I have to use control-click and select for it
to open in another tab to work.

Otherwise, I agree about adding new features or tweaking the present as
mentioned in the previous comments!.
(Assignee)

Comment 10

13 years ago
Anyone have any idea why this *isn't* working right now?

Did this ever work properly?

cl
(Assignee)

Comment 11

13 years ago
The reason this doesn't work is because we only check for command-return in the location bar or search field (not the content area).

What I can't figure out is why, when I remove the exclusion of the content area, the command key isn't getting passed to ContentClickListener::MouseClick properly. If I don't hold down cmd, and just hit return when a link is focused, I get it loaded in the current view. If I hold down cmd, I get a no-op, so it isn't that cmd is totally unrecognised -- it's that cmd seems to prevent the event from being passed into Gecko entirely.

cl
(Assignee)

Comment 12

13 years ago
Taking, and cc'ing smfr and mento for further advice.

cl
Assignee: mikepinkerton → bugzilla
Status: REOPENED → NEW
(In reply to comment #11)
> The reason this doesn't work is because we only check for command-return in the
> location bar or search field (not the content area).

I'm using build #2006080201. It also won't open a new tab when the address/search bars are hidden.

Opens in a new tab (as expected) when cmd-return:
1. by typing in address bar or search bar as long as those bars are shown.
2. by using auto-complete from address bar (http/s protocol only???) <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=326063>bug 326063</a>

Dosen't work when cmd-return:
1. by typing in address bar or search bar when they're hidden and from the search bar when it's minimized.
2. by using auto-complete from address bar (for about: only???) <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=326063>bug 326063</a>
3. when submitting a form from a web page.
That's a separate bug.  Filed as bug 347118.
Target Milestone: Camino1.1 → Camino1.2
Cmd-enter works (cmd-fn-return); see bug 358379 (which may be a dupe of this one).

Updated

12 years ago
QA Contact: bugzilla → tabbed.browsing

Updated

12 years ago
Target Milestone: Camino1.6 → Camino2.0
(Assignee)

Updated

12 years ago
Depends on: 358379
Fixed by bug 358379; no doubt these really were the same bug all along.
Status: NEW → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 358379

Comment 17

11 years ago
It showed up in Firefox as a regression from enabling Cocoa widgets, but it affected Camino the whole time?  Makes sense.
You need to log in before you can comment on or make changes to this bug.