Closed Bug 1649049 Opened 10 months ago Closed 10 months ago

nasm 2.15.01 fails to compile dav1d and breaks the build: cpuid.asm:47: out of memory

Categories

(Firefox Build System :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tnikkel, Unassigned)

References

(Blocks 1 open bug)

Details

My mach bootstrap updated nasm in home brew and now I get this error:

critical: /Users/tim/ffdbg/src/third_party/dav1d/src/x86/cpuid.asm:47: out of memory!

removing nasm from brew and using 2.14.03rc2 (2.14.03 doesn't seem to be in their downloads folder) seems to work fine. This is on macOS.

Note that backing out bug 1641887 does not fix this.

I'm seeing this as well. I suspect this will happen for every macOS developer who runs mach bootstrap today.

A quick brew install https://raw.githubusercontent.com/Homebrew/homebrew-core/469f92a366b9355255abebb0ae1752d90c237bf0/Formula/nasm.rb is a workaround.

Component: Bootstrap Configuration → General

Filed nasm bug.

Perhaps this is a bug only with the brew versions of nasm? If I run the same command using either the brew nasm or the nasm from https://www.nasm.us/pub/nasm/releasebuilds/2.15.01/macosx/nasm-2.15.01-macosx.zip the one directly from nasm.us produces a warning but I don't get the out of memory error.

Summary: nasm 2.15.01 fails to compile dav1d and breaks the build → nasm 2.15.01 fails to compile dav1d and breaks the build: cpuid.asm:47: out of memory

FWIW, we're seeing this on Chromium too: https://chromium-review.googlesource.com/c/chromium/src/+/2276297 so I think this might be a real nasm or (less likely) a dav1d bug.

(In reply to Dale Curtis from comment #5)

FWIW, we're seeing this on Chromium too: https://chromium-review.googlesource.com/c/chromium/src/+/2276297 so I think this might be a real nasm or (less likely) a dav1d bug.

It is a real nasm bug, and it's already fixed upstream (but not in a release)

Thanks, yeah after posting I found https://bugzilla.nasm.us/show_bug.cgi?id=3392687

Duplicate of this bug: 1650119

As of this morning brew has the new version of nasm, so re-bootstrapping should allow you to pick that up and have a passing build.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1651290
You need to log in before you can comment on or make changes to this bug.