Closed Bug 1649092 Opened 2 years ago Closed 2 years ago

Crash in [@ mozilla::dom::ContentParent::AssertAlive]

Categories

(Core :: DOM: Content Processes, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1654926
Tracking Status
firefox81 --- affected

People

(Reporter: gsvelto, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-93c6d53e-ffd6-42a1-88ea-8a80e0200628.

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::ContentParent::AssertAlive dom/ipc/ContentParent.cpp:1675
1 xul.dll static mozilla::dom::ContentParent::GetUsedBrowserProcess dom/ipc/ContentParent.cpp:932
2 xul.dll static mozilla::dom::ContentParent::GetNewOrUsedLaunchingBrowserProcess dom/ipc/ContentParent.cpp:1004
3 xul.dll static mozilla::dom::ContentParent::GetNewOrUsedBrowserProcess dom/ipc/ContentParent.cpp:1065
4 xul.dll static mozilla::dom::ContentParent::CreateBrowser dom/ipc/ContentParent.cpp:1351
5 xul.dll nsFrameLoader::TryRemoteBrowserInternal dom/base/nsFrameLoader.cpp:2587
6 xul.dll nsFrameLoader::TryRemoteBrowser dom/base/nsFrameLoader.cpp:2650
7 xul.dll nsFrameLoader::ShowRemoteFrame dom/base/nsFrameLoader.cpp:1068
8 xul.dll nsFrameLoader::Show dom/base/nsFrameLoader.cpp:939
9 xul.dll nsSubDocumentFrame::ShowViewer layout/generic/nsSubDocumentFrame.cpp:192

The first buildid for this crash is 20200628092814.

This is probably a dupe of... something.

Flags: needinfo?(nika)

:kmag has been working on these crashes, so will know which bug this is related to better.

Flags: needinfo?(nika) → needinfo?(kmaglione+bmo)

Randell, I think you were going to look into whether this is because we're winding up keeping a dead process in the preallocator pool.

Flags: needinfo?(kmaglione+bmo) → needinfo?(rjesup)

Randell has a related patch in bug 1654926.

Blocks: 1654926
Severity: -- → S2
Priority: -- → P2
Duplicate of this bug: 1658212
Crash Signature: [@ mozilla::dom::ContentParent::AssertAlive] → [@ mozilla::dom::ContentParent::AssertAlive] [@ libxul.so (deleted)@0x523dc79] [@ libxul.so (deleted)@0x55123d9]
Status: NEW → RESOLVED
Crash Signature: [@ mozilla::dom::ContentParent::AssertAlive] [@ libxul.so (deleted)@0x523dc79] [@ libxul.so (deleted)@0x55123d9] → [@ mozilla::dom::ContentParent::AssertAlive] [@ libxul.so (deleted)@0x523dc79] [@ libxul.so (deleted)@0x55123d9]
Closed: 2 years ago
Flags: needinfo?(rjesup)
Resolution: --- → DUPLICATE
Duplicate of bug: 1654926
You need to log in before you can comment on or make changes to this bug.