Closed Bug 1649135 Opened 2 years ago Closed 2 years ago

Request custom domains istead of searching

Categories

(Firefox :: Address Bar, defect)

77 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1634650

People

(Reporter: info, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

Since the latest update Firefox search custom domains like "foo.oitc.itn" instead of requesting it.

If I set keyword.enabled=false in about:config, I need to prefix all search requests with a "?" like in the old days.

Firefox 77.0.1 in macOS

Actual results:

Firefox use the default search engine to find "usefull" results

Expected results:

Try to resolve the hostname and navigate to the system. This was the default behavior for years.

Starting with Firefox 78, you can enter about:config into the address bar, then create a new boolean preference named browser.fixup.domainsuffixwhitelist.itn and set its value to true.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Component: Untriaged → Address Bar
Resolution: --- → DUPLICATE
Duplicate of bug: 1634650
You need to log in before you can comment on or make changes to this bug.