Closed Bug 1649371 Opened 1 month ago Closed 1 month ago

Turning EPT off still blocks some trackers

Categories

(Core :: Privacy: Anti-Tracking, defect)

76 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1644738

People

(Reporter: bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. Go to a website with trackers (e.g. heise.de), check that the console lists Request to access cookie or storage on “<URL>” was blocked because it came from a tracker and content blocking is enabled. 28

  2. Disable Enhanced Tracking Protection

The console shows Request to access cookie or storage on “<URL>” was blocked because it came from a tracker and content blocking is enabled. 10. Sometimes this requires an additional reload to show up. Note that the number of blocked trackers is less than with EPT, this is consistent.

I ran mozregression which narrowed the behavior down to this commit: https://phabricator.services.mozilla.com/D68189 (Change isOnContentBlockingAllowList in storageAccessAPIHelpers.js to use allowListed flag instead of permission.)

All mozregression settings besides the page to load on startup were left on default.

Actual results:

Apparently some trackers are still blocked even when the site is excluded. I’ve had it happen, that some files for Google Ads did not load.

Expected results:

All trackers and ads are allowed.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Protections UI

Tentatively marking as dupe of bug 1644738.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1644738
Component: Protections UI → Privacy: Anti-Tracking
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.