document.write to popup hangs Mozilla

VERIFIED INVALID

Status

()

Core
JavaScript Engine
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Steven Grimm, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This may be related to bug 112858 but some of the comments on that one don't
seem to apply to this.  The following simple page will hang the browser if you
click on the link:

---
<html>
<head>
<script language="JavaScript">
function showPopup() {
        var win = window.open('about:blank', 'testPopup',
                        'width=500,height=500,resizable,scrollbars,status');
        win.document.write('<h1>This is a test popup.  Enjoy it.</h1>');
}
</script>
</head>
<body>
<p>
<a href="javascript:showPopup()">Click here to hang Mozilla 1.1.</a>
</body>
</html>
---

This works fine under 1.0 and IE.
worksforme, current linux trunk build. (2002-08-26-08).

Comment 2

16 years ago
Hang ? Which hang ?

WFM - 1.1 final - WinXP.
(Reporter)

Comment 3

16 years ago
Aha!  Looks like this is a Multizilla bug, not a Mozilla one.  The hang happens
if I have Multizilla set to display tabs at the bottom of the window rather than
the top.  Closing this bug here; I'll report it to the Multizilla folks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
OK, thanks - marking Verified Invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.