Closed Bug 1649455 Opened 1 month ago Closed 1 month ago

Very long tail suggestions can overflow their line in the results panel

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 80
Iteration:
80.1 - June 29 - July 12
Tracking Status
firefox78 --- wontfix
firefox79 + fixed
firefox80 + fixed

People

(Reporter: harry, Assigned: harry)

Details

Attachments

(3 files)

If the first word in a long tail suggestion is changed by Google, then the entire string is returned as the tail. This breaks the layout as the ellipses are not needed at the beginning.

I've attached a screenshot of the current Firefox behaviour. Chrome handles this by just displaying these suggestions without the ellipses. Interestingly, for the string shown in the screenshot, they also don't display the first suggestion.

[Tracking Requested - why for this release]:
Tail suggestions will probably launch to the Release audience in 79. This is a visual bug that shouldn't be too hard to fix.

Harry, can we assign this bug to you?

Flags: needinfo?(htwyford)
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 80.1 - June 29 - July 12
Points: --- → 2
Flags: needinfo?(htwyford)

Turns out this is a tiny patch! Layout works fine even if there is a very small gap between the typed query and the start of the tail suggestion (screenshot attached). The only case that needs to be handled is the one where the tail suggestion starts exactly at the beginning of the typed query.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ba2d2916102
Stop tail suggestions that as the same length as the typed string from overflowing. r=mak
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80

Comment on attachment 9161902 [details]
Bug 1649455 - Stop tail suggestions that as the same length as the typed string from overflowing. r?mak

Beta/Release Uplift Approval Request

  • User impact if declined: Layout breakage in a new feature launching in 79.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line layout-only patch verified in Nightly.
  • String changes made/needed:
Attachment #9161902 - Flags: approval-mozilla-beta?

Comment on attachment 9161902 [details]
Bug 1649455 - Stop tail suggestions that as the same length as the typed string from overflowing. r?mak

Approved for 79.0b7.

Attachment #9161902 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.