news.metrocast.net gives me NNTP_ERROR while refreshing newsgroups

VERIFIED DUPLICATE of bug 103012

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 103012
15 years ago
9 years ago

People

(Reporter: David G King, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020827
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020827

While I'm refreshing my subscribed newsgroups from news.metrocast.net it stops
part way through the process. According to the NNTP log (which I will attach),
I'm getting an NNTP_ERROR.

Can't tell if this is a Mozilla problem, or a problem with the newsserver.

Reproducible: Always

Steps to Reproduce:
1. Click on arrow next to news.metrocast.net in my setup.

Actual Results:  
Refreshes 4-5 newsgroups only.

Expected Results:  
Refresh all my subscribed newsgroups.

It seems that the newsgroup it stops on has zero messages in it (on the server
or on my machine).
(Reporter)

Comment 1

15 years ago
Created attachment 96890 [details]
NNTP log

This NNTP log was created as per instructions at
http://www.mozilla.org/quality/mailnews/tests/sea-mn-newsgroup-function.html
Confirming, based on log.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
Some things have changed on my PC since I reported this bug, however, the bug
still exists.

I'm now running Windows XP SP1, and Mozilla 2002-09-26 TRUNK still has this
problem. I think OS is meant to be the lowest version for Windows bugs, and
their doesn't appear to be a generic Windows setting, so I'm leaving it at Win98.
(Reporter)

Comment 4

15 years ago
After a bit more digging into the log file, I notice a common trend.

The attached log has a similar line as this for nz.netstatus:-

0[2742d8]: (26e1a80) Receiving: 211 0 103 102 nz.org.net-society

However, I notice that both have a 0 (zero) as the second digit after
"Receiving". I don't see this on any "Receiving" line that works without a NNTP
error.
According to: http://www.ietf.org/rfc/rfc0977.txt

3.2.2.  Responses

   211 n f l s group selected
           (n = estimated number of articles in group,
           f = first article number in the group,
           l = last article number in the group,
           s = name of the group.)
   411 no such news group

So this means in your case:

0[2742d8]: (26e1a80) Receiving: 211 0 103 102 nz.org.net-society

It has a zero-length of articles in the group (estimated), followed by 2
numbers: the first article number (103) and the last article number (102), then
of course the requisite name of the newsgroup.

I'll look, we have a known bug when a server sends us a zero-length newsgroup on
a refresh.
 
I think this is bug 103012.  Please let me know if you agree.  Thanks.

*** This bug has been marked as a duplicate of 103012 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

15 years ago
I'm not totally sure, as I also note that the first article number is greater
than the last article number. Or maybe that is considered OK.....I'm not sure
where the article numbers come from.
(Reporter)

Comment 8

15 years ago
OK, from digging in the code, you're right, this is a dup of Bug #103012.
The code seems to handle a read total being higher than number of messages in group.

Marking VERIFIED.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.