Session information sharing

VERIFIED DUPLICATE of bug 117222

Status

()

Core
Networking: Cookies
--
major
VERIFIED DUPLICATE of bug 117222
16 years ago
2 years ago

People

(Reporter: Greg Robertson, Assigned: Stephen P. Morse)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using Mozilla 1.1 on Windows NT if i start 2 separate browser windows to test
the application I'm working on (Java based servlets, etc), and log in as 2
separate users the last user I log in as ends up in the session for both
browsers.  User is being put into the session using the java call:
session.setAttribute("some string", object);
This is almost certainly cookies.
Assignee: radha → morse
Component: History: Session → Cookies
QA Contact: claudius → tever
(Assignee)

Comment 2

16 years ago
That's because cookies are not local to a window but are global to the entire
browser app.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

16 years ago
I'm not positive this is correct.  IE 5.5 handles this correctly (e.g. two
windows same app etc there is no problem with this).  I originally had this
under session information.  
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Comment 4

15 years ago
I think it's more accurate to say that IE handles this differently from Mozilla;
there's no specification covering this so neither is "correct".  There is a
discussion ongoing about introducing some session cookie scoping into Mozilla,
see bug 117222.

*** This bug has been marked as a duplicate of 117222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
QA Contact: tever → benc
Resolution: --- → DUPLICATE

Comment 5

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.