Status

Core Graveyard
Java-Implemented Plugins
RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: v00d00, Assigned: Igor Kushnirskiy)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Really, it simply doesn't work.  Try it.  You will see.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Workee finee for mee, testing with a day old trunk CVS build and Linux, Java
plugin 1.4.0-b92

Please specify exactly what doesn't work, and which version of Java you use.

Comment 2

15 years ago
Reporter mailed:
--

Still no workee.  The Applet fails to initialize.  I am using an evil and
satanic version of MS 2000 and a moderately evil Java 1.3.1-b24. thanks

EM
----------------------------------------------------
java.io.IOException: Server returned HTTP response code: 403 for URL:
http://webpac.gno.lib.la.us/dynix/classes/WebClient.zip

	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.net.www.protocol.http.HttpURLConnection.getHeaderFields(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.checkCookieHeader(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.download(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.load(Unknown Source)

	at sun.plugin.cache.JarCache.get(Unknown Source)

	at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)

	at sun.misc.URLClassPath$JarLoader.getJarFile(Unknown Source)

	at sun.misc.URLClassPath$JarLoader.<init>(Unknown Source)

	at sun.misc.URLClassPath$2.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.misc.URLClassPath.getLoader(Unknown Source)

	at sun.misc.URLClassPath.getLoader(Unknown Source)

	at sun.misc.URLClassPath.getResource(Unknown Source)

	at java.net.URLClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at java.net.URLClassLoader.findClass(Unknown Source)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

load: class WebClient.class not found.

java.lang.ClassNotFoundException: WebClient.class

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

Caused by: java.io.IOException: open HTTP connection failed.

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	... 11 more
> and a moderately evil Java 1.3.1-b24

Please retest with 1.4.0

Comment 5

15 years ago
WFM WinXP and Java 1.4.0_01 as well. (But Java 1.3.1 failed to even start
initializing).

The applet takes a while to download, isn't exactly quick, and is somewhat CPU
intensive, So if you upgrade Java: delete cache before you try again, but give
it time to download.
(Reporter)

Comment 6

15 years ago
Works well, if somewhat slow with requested update to 1.4.0.  Slow even after
clearing cache.  

Comment 7

15 years ago
If it's supposed to bring down your system, it works just fine with Windows ME
and trunk build 2002081808. Prolly a dup of bug 142393.

Comment 8

15 years ago
Resolving as WFM based on comment 6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.