Closed Bug 1650118 Opened 5 months ago Closed 1 month ago

Remove GeckoRuntimeSettings.Builder.useMultiprocess and GeckoRuntimeSettings.getUseMultiprocess

Categories

(GeckoView :: General, task, P1)

Unspecified
All

Tracking

(firefox84 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
firefox84 --- fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

(Keywords: perf-alert, Whiteboard: [geckoview:m82] [geckoview:m83][geckoview:m84], [wptsync upstream])

Attachments

(8 files)

We're deprecating in 79 so we can remove in 82.

Priority: -- → P3
Priority: P3 → P1
Assignee: nobody → aklotz
Whiteboard: [geckoview:m82] → [geckoview:m82][geckoview:m83]
Whiteboard: [geckoview:m82][geckoview:m83] → [geckoview:m82] [geckoview:m83]

Depends on D90929

Depends on D90930

Note that I have placed these changes under the entry for version 82, as I
intend to uplift.

Depends on D90933

e10s is no longer a GeckoView option, so I'd like to remove it from test
harnesses when possible.

Depends on D90934

Whiteboard: [geckoview:m82] [geckoview:m83] → [geckoview:m82] [geckoview:m83][geckoview:m84]
Attachment #9178304 - Attachment description: Bug 1650118: Part 6: Update test harnesses; r=bc,ahal,sparky! → Bug 1650118: Part 6 - Update test harnesses; r=bc!,sparky!
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74fd3eb970a6
Part 1 - Remove non-e10s mode from GeckoView; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/66b9527aecad
Part 2 - Update GVE; r=agi
https://hg.mozilla.org/integration/autoland/rev/a6ca38804021
Part 3 - Update tests; r=geckoview-reviewers,agi,perftest-reviewers,sparky
https://hg.mozilla.org/integration/autoland/rev/2cb9109dee0a
Part 4 - Update api.txt; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/b9fa3dd9c05d
Part 5 - Update GeckoView changelog; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/4a7fc6398ad6
Part 6 - Update test harnesses; r=bc,sparky,perftest-reviewers

Comment on attachment 9177009 [details]
Bug 1650118: Part 1 - Remove non-e10s mode from GeckoView; r=#geckoview-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: It would still be possible to run GeckoView in single-process mode, which is not something we want to support.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: bug 1672285
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is just a setting removal.
  • String changes made/needed:
Attachment #9177009 - Flags: approval-mozilla-beta?
Attachment #9177010 - Flags: approval-mozilla-beta?
Attachment #9177012 - Flags: approval-mozilla-beta?
Attachment #9177013 - Flags: approval-mozilla-beta?
Attachment #9177014 - Flags: approval-mozilla-beta?
Attachment #9178304 - Flags: approval-mozilla-beta?
Regressions: 1672285
Attachment #9177009 - Flags: approval-mozilla-beta?
Attachment #9177010 - Flags: approval-mozilla-beta?
Attachment #9177012 - Flags: approval-mozilla-beta?
Attachment #9177013 - Flags: approval-mozilla-beta?
Attachment #9177014 - Flags: approval-mozilla-beta?
Attachment #9178304 - Flags: approval-mozilla-beta?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Grrr... gotta reopen.

Status: REOPENED → ASSIGNED

Now that we're e10s by default, we need to disable it for xpcshell.
Unfortunately we can't do this via user prefs because, by the time xpcshell
parses those, it's already too late: e10s has already been decided.

In an earlier patch, we've changed that env var to accept '1' for Android,
instead of the version string as on desktop.

Depends on D91640

Attachment #9182919 - Attachment description: Bug 1650118 - Remove useMultiprocess. → Bug 1650118: Part 8 - Remove useMultiprocess; r=esawin
No longer regressions: 1672285

Please keep in mind, these changes caused bug 1672552, which is docShellIsActive is not properly set when restoring session. I am totally unsure whether the additional fixes (part 7 and 8) fixes bug 1672552 or not.

That was probably because of a required pref change that was omitted in the original landing (bug 1649530). That has been fixed in a revision to part 1.

== Change summary for alert #27324 (as of Fri, 23 Oct 2020 06:06:58 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
10% instagram ContentfulSpeedIndex android-hw-g5-7-0-arm7-api-16-shippable cold 1,042.08 -> 941.42
3% amazon-search LastVisualChange android-hw-g5-7-0-arm7-api-16-shippable warm 4,659.00 -> 4,505.75
3% amazon-search android-hw-g5-7-0-arm7-api-16-shippable warm 1,041.59 -> 1,009.94
3% amazon-search FirstVisualChange android-hw-g5-7-0-arm7-api-16-shippable warm 915.33 -> 891.00
3% amazon-search SpeedIndex android-hw-g5-7-0-arm7-api-16-shippable warm 962.79 -> 938.25
3% amazon-search PerceptualSpeedIndex android-hw-g5-7-0-arm7-api-16-shippable warm 1,175.04 -> 1,145.17
3% amazon-search loadtime android-hw-g5-7-0-arm7-api-16-shippable warm 1,984.54 -> 1,934.29
2% amazon-search fcp android-hw-g5-7-0-arm7-api-16-shippable warm 905.40 -> 882.83
2% amazon-search android-hw-g5-7-0-arm7-api-16-shippable warm 1,039.57 -> 1,015.50

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=27324

Keywords: perf-alert
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f397e86fd61e
Part 1 - Remove non-e10s mode from GeckoView; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/0fd77fef3c95
Part 2 - Update GVE; r=agi
https://hg.mozilla.org/integration/autoland/rev/7f0a281a399e
Part 3 - Update tests; r=geckoview-reviewers,agi,perftest-reviewers,sparky
https://hg.mozilla.org/integration/autoland/rev/63cc752924f2
Part 4 - Update api.txt; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/cd5155e732d9
Part 5 - Update GeckoView changelog; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/ed357b8bb07e
Part 6 - Update test harnesses; r=bc,sparky,perftest-reviewers,jgraham
https://hg.mozilla.org/integration/autoland/rev/a99d1aae6e2e
Part 7 - Set MOZ_FORCE_DISABLE_E10S when running Android xpcshell tests; r=bc
https://hg.mozilla.org/integration/autoland/rev/ab6218dd84f5
Part 8 - Remove useMultiprocess; r=geckoview-reviewers,esawin
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/26308 for changes under testing/web-platform/tests
Whiteboard: [geckoview:m82] [geckoview:m83][geckoview:m84] → [geckoview:m82] [geckoview:m83][geckoview:m84], [wptsync upstream]
Upstream PR was closed without merging
Flags: needinfo?(aklotz)
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c0ee6278161e
Part 1 - Remove non-e10s mode from GeckoView; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/68a0c8b19d88
Part 2 - Update GVE; r=agi
https://hg.mozilla.org/integration/autoland/rev/2feccdfcb9e2
Part 3 - Update tests; r=geckoview-reviewers,agi,perftest-reviewers,sparky
https://hg.mozilla.org/integration/autoland/rev/2d20f9b282df
Part 4 - Update api.txt; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/11f71f99ed11
Part 5 - Update GeckoView changelog; r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/076c495bba18
Part 6 - Update test harnesses; r=bc,sparky,perftest-reviewers,jgraham
https://hg.mozilla.org/integration/autoland/rev/38c5c63d236d
Part 7 - Set MOZ_FORCE_DISABLE_E10S when running Android xpcshell tests; r=bc
https://hg.mozilla.org/integration/autoland/rev/c398f8d814b6
Part 8 - Remove useMultiprocess; r=geckoview-reviewers,esawin
You need to log in before you can comment on or make changes to this bug.