Text typed in Mozilla 1.1's URL Bar doesn't keep up with typing [slow text entry, typing, form input field]

VERIFIED DUPLICATE of bug 158782

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 158782
15 years ago
15 years ago

People

(Reporter: Nathan Finch, Assigned: kinmoz)

Tracking

({qawanted})

Trunk
mozilla1.2beta
PowerPC
Mac System 9.x
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

When typing a URL (any URL)in the location field the text being typed doesn't
keep up with my typing--this is new as of 1.1 (not happening in 1.1b or b4)

Reproducible: Always

Steps to Reproduce:
1. Type in a URL
2.
3.

Actual Results:  
text display doens't keep up with my typing (this text entry is keeping up with
my typing) not keeping up is disorienting

Expected Results:  
text display should keeping up with my typing

Comment 1

15 years ago
This is a dup. Adding DUPEME/qawanted.
Keywords: qawanted
Summary: When typing a URL (any URL)in the location field the text being typed doesn't keep up with my typing--this is new as of 1.1 (not happening in 1.1b or b4) → When typing a URL (any URL) in the location field the text being typed doesn't keep up with my typing--this is new as of 1.1 (not happening in 1.1b or b4)
Whiteboard: DUPEME

Comment 2

15 years ago
What are the specs of the machine are you on?  Does this happen for you on trunk
( ftp://ftp.mozilla.org/pub/mozilla/nightly/latest )?

To Editor--it sounds like the other slow typing bugs but the 1.1b (not
slow)->1.1 (slow) mystery means it might be more specific.
Assignee: jkeiser → kin
Component: HTML Form Controls → Editor: Core
QA Contact: tpreston → sujay

Updated

15 years ago
Blocks: 165130
(Assignee)

Comment 3

15 years ago
I think what's happening here is that the auto-complete timer code is
interfering with paint dispatching.

This problem was exposed by the async reflow/painting changes made by bug 141900.

Comment 4

15 years ago
This sounds like it will be made better when Kevin lands his change to make
reflow/paint events not get starved out by user events.

Updated

15 years ago
Summary: When typing a URL (any URL) in the location field the text being typed doesn't keep up with my typing--this is new as of 1.1 (not happening in 1.1b or b4) → ext being typed in Mozilla 1.1's URL Bar doesn't keep up with typing

Comment 5

15 years ago
*** Bug 165497 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Setting OS to Mac System 9.x per comment 5.
OS: MacOS X → Mac System 9.x

Comment 7

15 years ago
regression of bug 141900?

my queries
  query 1:
     comment: slow edit box
     resolution: duplicate
     other fields: -none-
     --> query failed
  query 2:
     comment: slow edit box
     status: unconfirmed, new, assigned, reopened
     other fields: -none-
     --> query failed
  query 3:
     summary: slow typing (operator: contains the string)
     status: unconfirmed, new, assigned, reopened
     --> bug 152137 --> bug 141900

Comment 8

15 years ago
chg summary based on summaries of dupes of 141900
Summary: ext being typed in Mozilla 1.1's URL Bar doesn't keep up with typing → Text typed in Mozilla 1.1's URL Bar doesn't keep up with typing [slow text entry, typing, form input field]

Comment 9

15 years ago
I don't think it's a regression of that bug, which I remember as genuinely slow typing, as in the 
text cursor would advance maybe twice a second.

This problem is that the text cursor advances with typing, but the characters are delayed in 
showing up.

Comment 10

15 years ago
*** Bug 165951 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
also reported on OS-X
(Assignee)

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.2beta

Comment 12

15 years ago
*** Bug 166965 has been marked as a duplicate of this bug. ***

Updated

15 years ago

Comment 13

15 years ago
confirming based on dupes
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

15 years ago

*** This bug has been marked as a duplicate of 158782 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 15

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.