selecting exit from file menu in bookmark manager completely closes the program, including browser

RESOLVED DUPLICATE of bug 39057

Status

RESOLVED DUPLICATE of bug 39057
16 years ago
14 years ago

People

(Reporter: ericeberg, Assigned: bugs)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

If I close the bookmark manager using the exit command in the file menu, the
entire program exits instead of just the bookmark manager exiting. However,
clicking on the X in the top right corner properly closes the bookmark manager
and leaves the browser active.

Reproducible: Always

Steps to Reproduce:
1. Double-click Mozilla to open web browser.
2. Select Bookmarks/Manage Bookmarks
3. Click File in the Bookmark Manager window, then exit.
4. Entire program exits (kills all active instances of the program). Wrong. Only
bookmark manager should exit.
Actual Results:  
Entire program exits (kills all active instances of Mozilla).

Expected Results:  
Selecting File/Exit from the bookmark manager should result in the bookmark
manager exiting and the browser window(s) remaining open.

Using the modern theme. Again, using the X in the top right corner of the
bookmark manager window closes it properly, but the bug lies in the File/Exit
command.
dup of bug 39057 (by way of dup bug 86192)

*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.