Closed Bug 1650475 Opened 1 month ago Closed 1 month ago

Enable GPU switching on Mac

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: wr-planning)

Attachments

(1 file)

No description provided.
Blocks: wr-mac-block
Severity: -- → S3
Priority: -- → P3

This still has texture conversion happening.

Whiteboard: wr-planning

My latest phabricator update fixes the texture conversion problem but causes us to panic on when calling glReadPixels with UNSIGNED_INT_8_8_8_8_REV on Linux.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ba6728447370f6890bf526daa2bd11e1d9ee9bd5&selectedTaskRun=IZG-EUyFQbqXHHXG-fgDJA.0

Assignee: nobody → jmuizelaar
Status: NEW → ASSIGNED
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8b058943779
Enable GPU switching on Mac. r=kvark
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

This seems to be working well.

Regressions: 1651889
You need to log in before you can comment on or make changes to this bug.