Closed Bug 1650500 Opened 5 months ago Closed 5 months ago

Entering a search term will redirect to a ticket with that very Alias

Categories

(bugzilla.mozilla.org :: Search, defect, P3)

Tracking

()

RESOLVED DUPLICATE of bug 1527053

People

(Reporter: erwinm, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Searched "search," while trying to find bug reports or enhancement requests regarding in-page search.

Actual results:

Got redirected to bug 1017135.

Expected results:

Search results. Probably too many results, so I'd need to add more terms to narrow them.

Many one-word searches get hijacked like this, often for bugs which have been closed.

Maybe a link for people who want to search.

And "find" gets hijacked to bug 695172.

That is due to the "Alias" feature.

Summary: Hijacking search terms → Entering a search term will redirect to a ticket with that very Alias

Workaround for this is to use advanced search, but that's not obvious.

Longer term solution could be:

  • when following the alias, add a notice at the top of the bug, "did you mean to search for the bug with alias 'x' or to search for 'x'" with a link to the advanced search URL
  • show the buglist for 'x' and add a notice to the top with the linked alias

I'd need to know more on what be more feasible to implement.

Marking as a S3 as there is a workaround.

Severity: -- → S3
Flags: needinfo?(glob)
Flags: needinfo?(erwinm)
Priority: -- → P3

I think bug 1472565 was supposed to fix this, but it's not being worked on at this time.

Depends on: 1472565

I previously reported a variation as bug 1527053. It was fixed, but the fix was reported as bug 1540245. That was fixed by reverting the fix...

I don't know what to do about the war over working search vs. aliases, but it may help to de-alias bugs which have been fixed for long enough.

Flags: needinfo?(erwinm)

(In reply to Emma Humphries, Bugmaster ☕️🎸🧞‍♀️✨ (she/they) [:emceeaich] (UTC-8) needinfo? me from comment #3)

Workaround for this is to use advanced search, but that's not obvious.

Longer term solution could be:

  • when following the alias, add a notice at the top of the bug, "did you mean to search for the bug with alias 'x' or to search for 'x'" with a link to the advanced search URL
  • show the buglist for 'x' and add a notice to the top with the linked alias

I'd need to know more on what be more feasible to implement.

Marking as a S3 as there is a workaround.

The easy fix would be to just redirect only to actual bug ids (numeric) and anything else just treat as a text search. For the text search part we would need to make sure the alias field is added to the search terms so that an aliased bug would show up in the search results. If the alias is specific enough, most of the time the bug list will just have the single row result I would imagine.

dkl

The easy fix would be to just redirect only to actual bug ids (numeric) and anything else just treat as a text search.

+1

The field after all does advertise itself as a search field.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Flags: needinfo?(glob)
Resolution: --- → DUPLICATE
Duplicate of bug: 1527053
You need to log in before you can comment on or make changes to this bug.