Closed Bug 1650531 Opened 1 year ago Closed 1 year ago

[Wayland] [Sway] Random segfault when popup is shown

Categories

(Core :: Widget: Gtk, defect)

78 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1645677

People

(Reporter: lynx1534, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Actual results:

Various popups randomly cause firefox to crash. I also have a lot of other issues with popups like menus being unresponsive or addon popups wrongly positionsed (some of them are already filed as bugs). Because of these issues I often have to reopen popup several times until it works correctly. And while I'm doing so, firefox tends to randomly crash when I try to open some popup another time. It sometimes crashes even when the tooltip should be show (like when I hover the tab headers).

OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

I was able to reproduce this crash in the latest nightly, here's the crash report https://crash-stats.mozilla.org/report/index/b21fd9c0-7c49-46ee-a43e-ac7700200704

In order to reproduce it I installed the uMatrix addon from AMO and started clicking on it's popup button until firefox crashed.

I swear, I'd have spent a ton of my time to debug and find a fix for this myself, if I knew where to start. It's very annoying that my browser randomly crashes every now and then as I use it.

Just reproduced this in FX79.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1645677
You need to log in before you can comment on or make changes to this bug.