Status

--
enhancement
RESOLVED DUPLICATE of bug 141986
16 years ago
14 years ago

People

(Reporter: cybr25, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mail and News should contain an Outbox where messages are stored before they 
are sent. The user can have the option to not send email messages until the 
end of his/her session when he/she clicks a 'Send all' button from the main 
Mail window.

Not only does this prevent anomalies such as messages being copied to the sent-
mail folder when an unexpected error prevents the message from actually being 
sent (as described in bug #57940), but it also allows the user to compose and 
review several messages before actually sending them.

This behaviour can be accomplished in Outlook Express by disabling the 'Send 
Message Immediately' option from the 'Send' tab of the options screen. When 
you press the 'Send' button on the composition window of each email, it is not 
sent immediately, but rather copied to the outbox for review. After review, 
the outbox messages can be delivered by selecting 'Send/Receive All' from the 
toolbar.
(Reporter)

Comment 1

16 years ago
Created attachment 96964 [details]
Outlook Express Options Screenshot

Outlook express includes the option shown which has the result of not
immediately sending messages, but rather copying them to an 'Outbox' for
review. Unchecking the 'Send Messages Immediately' box has this effect.

Comment 2

16 years ago
There's already an unsent message folder. Add an outbox folder might
confuse the user...
(Reporter)

Comment 3

16 years ago
Unsent Messages, eh? Why do I always feel silly after trying to be helpful? ;)

Terminology aside, the reason I missed this feature entirely is because there 
is no option to have a message copied to the 'Unsent Messages' folder by 
default. I would have to instead go into the 'File' menu and select 'Send 
later' for every single message. Moreover, once I have a collection of 
messages in the 'Unsent Messages' folder, there is no button on the toolbar to 
send the whole lot at once.

I think this is an important enhancement.

Comment 4

16 years ago
open the unsent message folder, press CTRL+A to select all messages,
then send?
* If you Go offline, then the default behaviour is "Send later"

* In my mozilla 1.0.1 there is a Send unsendt messages in the file menu.


this coupled witht the bug regarding making Mail/news support MS DUN for
send/recieve messages (can't remember the bug number), i would suggest marking
wontfix since the functionality is there.



Comment 6

16 years ago
Hi,

I don't think this should be marked as WontFix.  In OE if you unselect the "Send
Messages Immediately" option messages will go to the Outbox when the regular
Send button is clicked.  Then they will be picked up on the next automatic
send/receive if you have that enabled.  The end result was that you get about a
minute to realize if you made a mistake.  This wasn't perfect because if you
clicked send just as the auto send/receive was starting you had no time to
recover, but there's no reason this "grace period" can't be improved upon here.

I think what is needed is this:

  [x] Send Later by default?

  [x] Automatically send messages in Unsent Messages folder?
      [x] After |##| minutes.
    [...or...]
      [x] On exit.

With the "Send Later by Default" option the user can choose to have a grace
period without having to consciously choose File|Send Later, or without having
to be offline.  The "Automatically send messages in Unsent Messages folder"
option ensures that the user doesn't have to consciously remember to end that
grace period.  Auto send could happen a user defined number of minutes after the
message is commited to the Unsent Messages folder (which would be the
improvement over OE), or on the exit of Mail & News.

I'm sure we've all sent things that shortly there after we wish we could
retract, and I know that I'd be the first person to forget to send the messages
in the Unsent folder if they didn't go out on their own at some point.  For
these reasons I think this enhancement is very warranted.

Regards,

Ian

Comment 7

16 years ago
Just a question - why is the Unsent Messages folder in "Local Folders" rather
than in my POP3 account's folder list?  I didn't even know Mozilla had this
feature, because I never open my Local Folders list.  :)

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 141986 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.