Closed Bug 1650922 Opened 1 month ago Closed 1 month ago

Reader mode content appears after reader mode toolbar in accessibility tree

Categories

(Toolkit :: Reader Mode, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- verified
firefox77 --- unaffected
firefox78 --- verified
firefox79 --- verified
firefox80 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

First reported in https://github.com/mozilla/readability/issues/602 .

The reader-mode-processed content appears after the reader mode toolbar in the accessibility tree, which is a problem for screenreader users because they have to wade through the toolbar (which unfortunately isn't using the most semantic markup as it is) to get to the content every time.

Severity: -- → S2
Priority: -- → P1

What's the odds of getting this into 78.0.something at this stage?

Flags: needinfo?(jcristau)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9ca6c2325d9e
use aria-owns to move the toolbar down in the accessibility tree to avoid it interfering with the main content in reader mode, r=morgan
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

There's a possibility we'll have a 78.0.2 this week, please request uplift today so we also get this on beta.

Flags: needinfo?(jcristau)

Comment on attachment 9161751 [details]
Bug 1650922 - use aria-owns to move the toolbar down in the accessibility tree to avoid it interfering with the main content in reader mode, r?morgan

Beta/Release Uplift Approval Request

  • User impact if declined: Reader mode stops working well for users of assistive technology
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Setting "verified" to yes because Morgan explicitly tested this patch with voiceover.

For QE testing, it should be possible to test on Windows with NVDA, and check that after loading a page in reader mode, the first content that receives accessibility focus (ie that gets read out when navigating through the page with NVDA's keyboard shortcuts) is the main content, rather than "list" elements that correspond to the toolbar on the side.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only affects what we expose to AT users, is a very tiny markup alteration, and restores parity with 77 in terms of where the toolbar appears in the document order
  • String changes made/needed: n/a
Attachment #9161751 - Flags: approval-mozilla-release?
Attachment #9161751 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9161751 [details]
Bug 1650922 - use aria-owns to move the toolbar down in the accessibility tree to avoid it interfering with the main content in reader mode, r?morgan

Approved for 79.0b5. Also nominating for ESR78 under the assumption that we'll want it there too eventually.

Attachment #9161751 - Flags: approval-mozilla-esr78?
Attachment #9161751 - Flags: approval-mozilla-beta?
Attachment #9161751 - Flags: approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Comment on attachment 9161751 [details]
Bug 1650922 - use aria-owns to move the toolbar down in the accessibility tree to avoid it interfering with the main content in reader mode, r?morgan

fix for a new accessibility regression, approved for 78.0.2

Attachment #9161751 - Flags: approval-mozilla-release?
Attachment #9161751 - Flags: approval-mozilla-release+
Attachment #9161751 - Flags: approval-mozilla-esr78?
Attachment #9161751 - Flags: approval-mozilla-esr78+

Reproduced bug on an older nightly build, confirm that the first content that receives accessibility focus is the readers' mode list of elements.

Verified as fixed on Windows 10 x64 with Nightly 80.0a1, Build ID 20200708094217 and Beta 79.0b5, Build ID 20200708005253 - the fist content READ by NVDA is the content of the page.

Verified as fixed on Windows 10 with Firefox 78.0.2 (Build ID 20200708170202), ESR 78.0.2esr
(Build ID 20200708170510) and ESR 78.1.0esr (Build ID 20200708130121 - build from treeherder - https://treeherder.mozilla.org/#/jobs?repo=mozilla-esr78&revision=6b778891f6bc5e305ce5325f9b90698ff23ad5ad).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.