Closed Bug 1651087 Opened 1 month ago Closed 1 month ago

Crash in [@ mozilla::dom::XRWebGLLayer::EndAnimationFrame]

Categories

(GeckoView :: General, defect)

Unspecified
Android
defect

Tracking

(firefox79 fixed, firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox79 --- fixed
firefox80 --- fixed

People

(Reporter: fluffyemily, Assigned: imanol)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

Affects FxR exclusively.

This bug is for crash report bp-e8fa3fe6-84bc-4c6a-a50b-7d7570200707.

Top 8 frames of crashing thread:

0 libxul.so mozilla::dom::XRWebGLLayer::EndAnimationFrame dom/canvas/XRWebGLLayer.cpp:253
1 libxul.so mozilla::dom::XRSession::StartFrame dom/vr/XRSession.cpp:322
2 libxul.so mozilla::gfx::VRDisplayClient::StartFrame gfx/vr/VRDisplayClient.cpp:87
3 libxul.so mozilla::gfx::VRDisplayClient::FireEvents gfx/vr/VRDisplayClient.cpp:167
4 libxul.so mozilla::gfx::VRManagerChild::UpdateDisplayInfo gfx/vr/VRDisplayClient.cpp:55
5 libxul.so mozilla::gfx::VRManagerChild::RecvUpdateDisplayInfo gfx/vr/ipc/VRManagerChild.cpp:273
6 libxul.so mozilla::gfx::PVRManagerChild::OnMessageReceived ipc/ipdl/PVRManagerChild.cpp:636
7 boot-telephony-common.oat boot-telephony-common.oat@0x43c571 
Duplicate of this bug: 1651097
Assignee: nobody → imanol
Status: NEW → ASSIGNED
Pushed by igorostizaga@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a5cbdd9d659
Check if the session is ended before processing XRSession::StartFrame() r=kip,daoshengmu
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

Comment on attachment 9161915 [details]
Bug 1651087 - Check if the session is ended before processing XRSession::StartFrame()

Beta/Release Uplift Approval Request

  • User impact if declined: This is the number 2 crasher in Firefox Reality
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It only add a null check and an early return if the session has ended. Additionally this issue is in the WebXR code path which is currently only used in Firefox Reality.
  • String changes made/needed: no
Attachment #9161915 - Flags: approval-mozilla-beta?

Comment on attachment 9161915 [details]
Bug 1651087 - Check if the session is ended before processing XRSession::StartFrame()

Approved for 79.0b6.

Attachment #9161915 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.